Results 1 to 10 of 10
  1. #1

    Engine Operating Temperature???

    Ok, about 3 hours are on my ski since the bearings went in my supercharger. they didnt grenade, but I could hear a noise in my intake so I pulled it off and the shaft in the charger was moving up and down. I didnt notice any other damage and the charger was replaced under warranty. Since I installed the new warranty charger my engine has been running warmer. Before the charger went I was always sitting at 188/189, no I am at 195/197.

    Is there any logical reason for something like this?

    This is on my RXTX 260 mods in sig

    Thanks, I hope there is someone that can help me with this


  2. #2
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    The waters warmer and the airs warmer than last time you where out

  3. #3
    It is actually cooler now then what it was before...

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Did the old sc touch down?

  5. #5
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    My engine is always around 192.2 at idle and rise to 199.4 when riding hard.
    Ambient temp is 86 and water 77 or so.

  6. #6
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Same here 195-199.

  7. #7
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,371
    +1
    980
    The thermostat regulates the temps.......its a 195* stat. Your temps are normal. I use a Riva 160* stat and per the temp gauge runs 150-160*. The oil temp runs at about 190*, and as high as 210-220* when running WOT!

    Sounds like the OP lost a bearing in the S/Cer......were the 2 oil pumps and oil cooler flushed?

  8. #8
    Quote Originally Posted by beerdart View Post
    Did the old sc touch down?
    Not sure what you mean?

  9. #9
    Quote Originally Posted by 1tommygunner1927 View Post
    The thermostat regulates the temps.......its a 195* stat. Your temps are normal. I use a Riva 160* stat and per the temp gauge runs 150-160*. The oil temp runs at about 190*, and as high as 210-220* when running WOT!

    Sounds like the OP lost a bearing in the S/Cer......were the 2 oil pumps and oil cooler flushed?
    The bearing never flew apart, there was just an extreme amount of play in it, I could move the shaft up and down, and the impeller just barely scraped the housing inside the supercharger, no filings made it out of the charger though. The seal went as well and any aluminum dust was caught by the oil from the seal. Very minimal.

    So no I never needed to clean out the oil pumps.

  10. #10
    It appears that I am still well within reason though and even running cooler then some skiis out there. Great to know!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "normal" engine operating temps?
    By tornado34 in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-14-2014, 04:16 AM
  2. Operating Temperature GTX
    By Mighty Mouse in forum 2-Stroke Performance
    Replies: 9
    Last Post: 06-05-2012, 08:13 AM
  3. Engine compartment temperature during regular operation.
    By Project_X in forum 4-Tec Performance
    Replies: 26
    Last Post: 12-27-2011, 05:27 PM
  4. Polaris SL780 Engine Operating Temperature??
    By JGringo in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-21-2010, 12:32 AM
  5. Engine Temperature Gauge
    By beachbum0286 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-07-2010, 04:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •