Results 1 to 10 of 10
  1. #1

    Join Date
    Jun 2007
    Location
    NY
    Posts
    23

    04 RXP questions

    Hello, I recently finished rebuilding the motor on an 04 RXP that I picked up. It had a ceramic washer failure and the previous owner didn't do any motor repairs after fixing the SC which then led to a timing chain failure. I got to take the jet ski for the first ride yesterday and it seemed to not have as much power as my 05 GTX(185hp). I wondered at first if it was just me not used to VTS as I have never had a jet ski with that option before. The way it feels when I take off is as if I have all the rev/rpms but not the same push as the GTX. The feeling is similar to that of a manual car with a slipping clutch. Is there a different pitch to the impeller that would make the rxp feel lower on power than the GTX? I did adjust the height of the trim to a couple of different locations thinking maybe that would make a difference but it didn't seem to. I have yet to verify that the clutches aren't slipping on the supercharger but the fact that I can get up above 6100rpms would mean that the supercharger is ok right? There was some rust on the drive shaft going into the impeller(more so on the splines to the impeller) but I don't know if there was enough to slip. I didn't push it too hard as I had just got it back together but any input would be appreciated.


  2. #2
    What RPM are your seeing when you accelerate? How do the wear ring and impeller look? WHat is your RPM at WOT?

  3. #3

    Join Date
    Jun 2007
    Location
    NY
    Posts
    23
    RPM at WOT hit about 8000. The impeller seemed decent but did have some dings. As for the wear ring I would have to check that. In order to check do I pull the pump and then take it apart? If the wear ring were damaged would that allow water to get by without getting the push?

  4. #4

    Join Date
    Jun 2007
    Location
    NY
    Posts
    23
    I just pulled the pump and checked out the wear ring and it is dug into. I will also replace the impeller since it is decently dinged up and I think that should cure my problem. Considering what I have read I will probably go with the Solas 14/19r as I have a stock machine otherwise. Any recommendations on the best resource to go through for purchasing the impeller, wear ring, and the impeller tool?

    Thanks for the info.

  5. #5
    Flynlow's Avatar
    Join Date
    Sep 2010
    Location
    Malvern, Arkansas, United States
    Posts
    60
    I wouldn't buy the wear ring from anybody but the stealership (oem). Removing the wear ring on these is super easy. Put the pump and new wear ring in the freezer for 1.5 to 2 hrs grab the wear ring with some pliers pull it out and slide the new one in. As far as the tool and impeller the greenhulk store will have it.

  6. #6
    A 14/19R might be a bit tall without any mods. You will likely not hit your top RPM as a result. Regarding the wear ring, it is a crapshoot whether removing it and replacing it is easy or not. If it is original, then putting it in the freezer will allow it to slide right out like Flynow says. But the freezer method rarely works with either removing or installing the new ones they make now. It depends on the inside diameter of your pump. The last few I replaced, I needed to use my shop press to get them in. And the freezer trick won't work to remove them, I had to use a dremel tool to score the late ones.

    There is a TSB that talks about the change to the latest wear rings. They went to a different material, and a larger diameter, because they had issues with wear rings spinning in the bore.

  7. #7

    Join Date
    Jun 2007
    Location
    NY
    Posts
    23
    Thanks, I ordered the Solas 14/19R and an OEM wear ring. I guess if I have to mod the ski more afterwards it wouldn't make me sad I will give the freezing route a try and if that doesn't work cut the old one out and put the new one in with the press. Hopefully be able to give it a run Thursday or Friday.

  8. #8
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    the best part of the freezer trick is you do not have to remove the impeller. if it isnt working. then you have to remove the impeller and use a dremel on the wear ring.
    see if anyone on here has a like new oem impeller for a rxp, you might get several in mint condition for a good price. rather than going aftermarket and paying top dollar and then having to mod something else...
    so many people swap out their oem impellers!!!!!!!!!! they make really cool paperweights!
    although an air intake mod is so easy and cheep

  9. #9
    Flynlow's Avatar
    Join Date
    Sep 2010
    Location
    Malvern, Arkansas, United States
    Posts
    60
    Quote Originally Posted by Sea Dood View Post
    A 14/19R might be a bit tall without any mods. You will likely not hit your top RPM as a result. Regarding the wear ring, it is a crapshoot whether removing it and replacing it is easy or not. If it is original, then putting it in the freezer will allow it to slide right out like Flynow says. But the freezer method rarely works with either removing or installing the new ones they make now. It depends on the inside diameter of your pump. The last few I replaced, I needed to use my shop press to get them in. And the freezer trick won't work to remove them, I had to use a dremel tool to score the late ones.

    There is a TSB that talks about the change to the latest wear rings. They went to a different material, and a larger diameter, because they had issues with wear rings spinning in the bore.
    Maybe I got some old stock as I just replaced mine 2 weeks ago. Kind of makes me want to go buy another one to have for the future.

  10. #10
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,181
    +1
    98
    Quote Originally Posted by Flynlow View Post
    Maybe I got some old stock as I just replaced mine 2 weeks ago. Kind of makes me want to go buy another one to have for the future.
    I just replaced my neigbours wear ring and it was definattly differnt than his original one. The old ones are white a very pure white and a solid white. The new one was white, but a semi translucent white and not as pure a white. The new ones seem to be made of a harder material too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 07-06-2010, 08:38 AM
  2. Replies: 7
    Last Post: 07-02-2010, 01:35 AM
  3. 04 RXP Question about a (Sensor) light coming on display at start up?
    By davidrxp in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-01-2010, 07:57 PM
  4. 04 RXP question about a (sensor) light coming up on display
    By davidrxp in forum Sea Doo ECU Support
    Replies: 0
    Last Post: 07-01-2010, 07:52 PM
  5. 04 RXP question
    By fazznick in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 03-19-2007, 04:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •