Results 1 to 4 of 4
  1. #1

    96 XP 800 X4 problems (we need experts to help)

    hi i have a 96 xp 800 in the x4 hull, and it has a really bad "lag" i have to hold it full throttle for 5-10 seconds depending on the seadoo's mood till it will hit full throttle, as well as when i turn left or sharp to the right it slows and looses RPM. please help


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Carbs....Have you replaced your fuel lines yet??

  3. #3
    woodsrider40's Avatar
    Join Date
    Jul 2012
    Location
    Clinton TN
    Posts
    171
    +1
    3
    Have you install new needle seats, what's the popoffs ? As Tiny states, have you replaced the gray tempo lines & cleaned out the fuel pit cock.

  4. #4
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Sounds like carbs are in need of a little tlc.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I need some help. 96 xp 800
    By SteveHuffman in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-16-2011, 10:15 PM
  2. Problem firing up '96 XP 800
    By SideFX in forum 2-Stroke Performance
    Replies: 11
    Last Post: 05-02-2010, 09:34 PM
  3. 96 XP 800 starts then stalls.
    By skirtchaser in forum 2-Stroke Performance
    Replies: 12
    Last Post: 04-18-2008, 01:28 PM
  4. '96 XP 800, no spark
    By waterbug in forum 2-Stroke Performance
    Replies: 25
    Last Post: 03-06-2008, 09:43 PM
  5. Hopefully purchasing my first sea-doo tommorrow! 96 xp 800
    By jcc011185 in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 11-29-2006, 03:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •