Results 1 to 4 of 4
  1. #1

    polaris virage i back fires

    friend came back in with ski saying it would not runs but back fires and spits like it is out of time
    friiend had a friend that worked on these skies awhile back and recommended that i check the reeds they looked new no dirt our chips in them back together and still bak fire took moteor out to make sure that we had not spun the fly wheel key all looked good back in boat still back fireing and trys to run but takes a lot of turing over inbetwen backs fire.
    wife ski and she is not happy
    ANY IDEAS WOULD BE GREATFULE


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    So it was working properly and then it just shut down? And since then it backfires but does not run? Is this correct?

    If yes, then it sounds like the EMM has failed and needs repair. See my signature links for DFI Technologies regarding EMM module repair

  3. #3
    what about the crank sensor and is there any way to make sure it is the emm module that is bad $249.00 dollors just to check it out

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by robin jentzen View Post
    what about the crank sensor and is there any way to make sure it is the emm module that is bad $249.00 dollors just to check it out
    You certainly can ohm test the CPS and check the sensor bottom end for any signs of damage or metal debris.

    The best confirmation for a bad EMM is to install another known good one. Other than that, DFI knows these units well and can upgrade other known weak internal components while they have it open.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Virage 700cc - Back to Life.
    By Policeman in forum Polaris Projects
    Replies: 9
    Last Post: 07-07-2013, 10:17 PM
  2. 2001 polaris virage TXi Not Firing
    By mims818 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-29-2011, 04:20 PM
  3. 2002 Polaris Virage Will not fire
    By drunken monk in forum Polaris Open Discussion
    Replies: 15
    Last Post: 07-03-2011, 09:16 AM
  4. 2002 polaris virage txi will not run, just back fires
    By motormadness in forum Polaris Open Discussion
    Replies: 15
    Last Post: 08-16-2010, 07:32 PM
  5. 2002 virage i back fires when tring to start
    By goduke in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-27-2008, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •