Results 1 to 10 of 10
  1. #1

    Join Date
    Jul 2012
    Location
    Denmark, Scandinavia
    Posts
    6

    Seadoo RXP 2004 - strange problem with RPM

    I have a strange problem with my Seadoo RXP 2004 and hope that someone can help me. At full throttle the RPM is very stable at 7750 - 7800 and the engine runs very smooth and nice. But at half speed (and from zero to full speed) the RPB is very unstable. It almost feels and sounds like an unstable fuel supply. The engine is coughing all the way to full speed.
    The supercharger was rebuild only 60 hours ago. Total hours is 130.
    Any idea what the problem is?


  2. #2

    Join Date
    Jul 2007
    Location
    Montgomery, AL
    Posts
    257
    +1
    1
    worn out wear ring? Hitting the rev limiter? Are you getting cavitation? How does the ski come out of the hole?

  3. #3

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    I have seen a larger percentage of 4 techs that responded well to cleaning the fuel injectors over here-- symtoms were difficulties in starting and mid range surge.

  4. #4

    Join Date
    Jul 2012
    Location
    Denmark, Scandinavia
    Posts
    6
    Bama: The wear ring was replaced with a stainless steel model 45 hours ago. I do not know what you mean with "rev limiter". Cavitation? - I do not think so. In that case I would feel cavitation at high speed too. Upon acceleration the engine is "farting/cut out" - ie like air bubbles in the gas supply.

  5. #5

    Join Date
    Jul 2012
    Location
    Denmark, Scandinavia
    Posts
    6
    Jim: Sounds most likely that the fuel injectors needs cleaning. But then again: Why does the engine run perfectly when reaching full speed?

  6. #6

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    Quote Originally Posted by kmagnus View Post
    Jim: Sounds most likely that the fuel injectors needs cleaning. But then again: Why does the engine run perfectly when reaching full speed?
    My skis also would run "normal" peak RPM, but obviously there was a problem-- most noticable in the midrange and the difficulties in getting them started-- also some would stall out a couple times before they were warmed up.

  7. #7

    Join Date
    Jul 2012
    Location
    Denmark, Scandinavia
    Posts
    6
    My ski stall out after it is warmed up.
    I will dismantle and clean the fuel injectors later on today, and give you some info about the result.

  8. #8

    Join Date
    Jul 2007
    Location
    Montgomery, AL
    Posts
    257
    +1
    1
    A stainless wear ring will wear the edges of the prop (more so with stock motor mounts) and increase clearance causing cavitation. If your prop is worn then it would have to be built back up. If it is cavitating it will bounce off the revlimiter till it builds up speed. If your pump is hooking up good then you could try new plugs and cleaning injectors and check the stick coils for corrosion.

  9. #9
    icdoo's Avatar
    Join Date
    Feb 2011
    Location
    Iowa
    Posts
    381
    +1
    23
    Quote Originally Posted by Bama View Post
    A stainless wear ring will wear the edges of the prop (more so with stock motor mounts) and increase clearance causing cavitation. If your prop is worn then it would have to be built back up. If it is cavitating it will bounce off the revlimiter till it builds up speed. If your pump is hooking up good then you could try new plugs and cleaning injectors and check the stick coils for corrosion.
    +1.. Check for pitting on prop. Thats low for peak RPM. You should be at 8100, unless you're at higher elevation. +1 on injector cleaning also, or possibly plugs?

  10. #10

    Join Date
    Jul 2012
    Location
    Denmark, Scandinavia
    Posts
    6
    I have added some injector cleaning to the fuel and repladed the spark plugs. Now it is running just perfect Thanks for all your help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. seadoo rxp max out at 6500 rpm with WOT
    By rxpsquad in forum 4-Tec Performance
    Replies: 21
    Last Post: 03-20-2012, 10:21 AM
  2. Problem with RPM and top speed
    By rxp1972 in forum 4-Tec Performance
    Replies: 27
    Last Post: 07-17-2010, 03:02 PM
  3. Problem with rpm (1999 ultra 150)
    By Stephen Meyer in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 03-08-2010, 05:14 PM
  4. FS Fuel pump Seadoo rxp 2004-2007
    By 2005cdoorxp in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-19-2009, 07:17 AM
  5. FS Fuel pump Seadoo rxp 2004-2007
    By 2005cdoorxp in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-16-2009, 09:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •