Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: RXP new B

  1. #1

    Join Date
    Jul 2012
    Location
    Kingston Ontario Canada
    Posts
    7

    Question RXP new B

    Hay every one
    Im new to this site and to riding im a piston head trying to sort out a problem im having with my RXP 2004
    i baught it as a basket case and i rebuilt the engine i went 40 over on pistons [wisco] and the head has been decked with new valves thats the sum up
    The problem im having is oil on both sides of the s/c i had it out for a 3hr. run it does a solid 65mph but it felt week
    on top end so i went through the basics check oil it was high so i went to this site and read and learned alot i drained off some oil between the bends right and i took it for another run now i get a warning OIL i pull the teather wait 2min and it goes again for 2 to 3 min then OIL again i got it back to shore check oil its a little low so i pull the s/c and oil on both sides
    I could use some pro input any help would be great Thanks from a newb



  2. #2
    tick.. tick.. RXPteamtimebomb's Avatar
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    726
    +1
    13
    Could be the supercharger seal leaking.. Many replace with a viton seal sold in the online store here.. I have run one before to stop my charger leaking oil.. I'm sure more will chime in with more advice

    Part -
    http://www.4-tecperformance.com/inde...oducts_id=1664

    The oem seal can begin to warp and not seal under high temperatures, the one sold in the online store has a higher tolerance to heat and if you are getting oil in your charger and in the intake tube when you pull it off the charger your oem seal is probably leaking

  3. +1 by:


  4. #3

    Join Date
    Jul 2012
    Location
    Kingston Ontario Canada
    Posts
    7
    ive rebuilt the s/c the oil leek is gone thanks
    my top speed is 60 mph that is slow i must be missing something any pointers would be great
    Thanks

  5. #4

    Join Date
    Jul 2012
    Location
    Kingston Ontario Canada
    Posts
    7
    what is the top speed of a stock RXP and what max RPM

  6. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    what are your RPMs, and what prop are u using?

  7. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    roughly 67-68 stock @8100 rpms

  8. #7

    Join Date
    Jul 2012
    Location
    Kingston Ontario Canada
    Posts
    7
    the drive line is stock and ive reset the computer to alow 8400rpm but i cant get it there it seems to slug out around 7400rpm and im scared of hurting it
    it stops pulling hard at 60 mph give or take i must be missing something from 60 to 70 should it pull strong or do you just keep it pined and wait for it to get there

  9. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    u may be over propped, have a boost leak, charger slip could be low.
    U may not have the knock sensor piggyback harness installed.
    the prop nosecone could be loose, and moving up the shaft.
    What ECU are u running?

  10. #9

    Join Date
    Jul 2012
    Location
    Kingston Ontario Canada
    Posts
    7
    stock ecu the s/c slip is right from the bomber tec sheets i will check for leeks and the other items you listed
    thanks for your help i will keep you posted

  11. #10
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,325
    +1
    641
    If you are running a stock 04 ecu rev limit is 8200 and hits soft limit at 8150.. Also the 04 only measures rpm's in 50 rpm increments. 8100 is spot on rpm

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 rxp new trailer perfect cond
    By marc777 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-24-2008, 06:45 PM
  2. RXP new S/C Rebuild....Lost 300 RPMs!!!!!
    By Pirates81 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-10-2008, 05:40 PM
  3. 2007 RXP: New engine/metal washers
    By SaskRXP07 in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-10-2007, 06:28 PM
  4. rxp new hull
    By ActionR32 in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-10-2006, 08:59 AM
  5. Installed RXP new grate , have Questions??????
    By chris7613 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-24-2006, 09:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •