Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Polaris emm problems.

    Has anyone installed a remanufactured 4010408-R. A guy I know has one but it only last an half hour on the water and dies. Thought maybe it could be fixed or it maybe it is something else. I am going to ship mine to get rebuilt but don't know how long that may take and don't want to lose the season. I thought maybe I could use his or buy it, if I could figure out the problem.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    You can't use another EMM unless it is mapped to the injectors you have on your ski. You could use it if you also installed the injectors that are with that EMM.

  3. #3
    So is that why it only last a half hour, because it is not mapped to those injectors? Could I have it mapped to my injectors? Sorry new to this EMM thing. I just bought them thinking I was getting a good deal, but it is turning into more then i thought.

  4. #4
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    You can have it mapped if you have the original floppy disc that came with each injector containing the calibration data. Which I doubt you have.

  5. #5
    ValBugi's Avatar
    Join Date
    May 2012
    Location
    Oakville, Ontario
    Posts
    275
    +1
    21
    Any Polaris dealer that still deals with PWC products can do it for you.. a shop in my area only charges $40 to program the EMM

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    If the engine is shutting down after 30 minutes then the problem is nothing to do with injector mapping.

    Make very sure your EMM is getting proper water flow to keep it cool.

    See my signature links for more info regarding how the Ficht fuel injection system works, and some common issues.

    If water cooling flow is good and the various sensors test good then you may need to send the EMM in for repair.

  7. #7
    Harsax13's Avatar
    Join Date
    Jul 2012
    Location
    Cleveland, Ohio
    Posts
    216
    +1
    3
    What is the best way to make sure the EMM is getting the water flow that it needs?

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by Harsax13 View Post
    What is the best way to make sure the EMM is getting the water flow that it needs?
    Remove and inspect the water hoses, stator elbows, etc.

    Disconnect EMM water exit hose at rear hull fitting and verify water flow out of EMM (cap the hull exit fitting if hull will be floating in the water during testing )

  9. #9
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    I got one for a customer. It lasted one season then it was doing the same thing your friends is. ride it for a half hour. Then spit, sputter and backfire but no run. Can't even have DFI fix it cause they will just tell you there's nothing wrong with it. And if the water hoses were clogged and the EMM was overheating, I would expect the check engine light to come on.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by GGG View Post
    ... And if the water hoses were clogged and the EMM was overheating, I would expect the check engine light to come on.
    Sometimes the EMM just cooks itself without saying boo. No check engine light, not even a trouble code. Just reports excessive max EMM 'cooling water' temperature in Digital Wrench history.

    Sometimes DFI will warm the EMM under test in an 'oven' to diagnose some issues related to temperature and time.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris 1200DI Ficht EMM problem, Burned out C27 & C28, Q6 - please help
    By turtle_soup in forum Polaris Open Discussion
    Replies: 11
    Last Post: 10-10-2013, 04:54 PM
  2. 1998 polaris slxh problem/advice
    By bobbyhill6 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-06-2008, 11:41 PM
  3. polaris emm ficht f/s cheap
    By dav_dman in forum Polaris Classifieds
    Replies: 8
    Last Post: 05-03-2008, 11:24 PM
  4. Polaris SLTH Problem!
    By smoke20 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 07-19-2007, 01:30 PM
  5. 96 polaris sl700 problems
    By markamus in forum Polaris Open Discussion
    Replies: 31
    Last Post: 05-27-2007, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •