Results 1 to 3 of 3
  1. #1
    thetolleyman's Avatar
    Join Date
    Jul 2010
    Location
    Williamsburg, VA
    Posts
    562
    +1
    2

    Ultra 150 running poor unless fuel on "reserve"

    Ultra cut off on me a few times today. Started right back up, then would occasionally bog, then pick back up. Got more and more frequent. I switch over the "reserve" just out of curiosity and never had the problem. Swithced back to "on" cut off on me again. Was hard to start this time, but made it to the ramp. Fuel selector issue, maybe?


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,009
    +1
    283
    Put gas in it!

    Seriously, sounds like the pickup needs to come out.

  3. #3
    thetolleyman's Avatar
    Join Date
    Jul 2010
    Location
    Williamsburg, VA
    Posts
    562
    +1
    2

    issue

    I was hoping to avoid that, looks like a pain. Does that aluminum refinforcement bar have to come out. I don't see a way around it, its only a few inches directly over the pickup assembly? I may look at it tonite if I can. I'll remove and clean the selector switch and fuel filter first, pretty easy to do.


    Quote Originally Posted by steve45 View Post
    Put gas in it!

    Seriously, sounds like the pickup needs to come out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ultra 150: running on 2 cylinders at 4500 rpms
    By skoolball23 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-27-2013, 09:22 PM
  2. 2000 ultra 150, runs perfect in the water but no water from pissers on hose
    By dsnotgood in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-02-2012, 04:08 PM
  3. Ultra 150 running away on trailer??????
    By nz253 in forum Kawasaki Open Discussion
    Replies: 9
    Last Post: 08-19-2011, 07:44 PM
  4. 99 ultra 150 running max 4.2k, then takes off full throttle?
    By screamindemon in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-16-2011, 07:15 PM
  5. ultra 150 running hot
    By turbogn in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 03-28-2010, 03:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •