Results 1 to 5 of 5
  1. #1

    electrical problems with my 98 gp1200

    Any help would be appreciated..

    I'm kinda new to this whole jetski thing so please bear with me..

    I had the drive side crank bearing go bad , replaced and rebuilt top end. Then during reassembly, i noticed the stator was torn up, all the poles were split and bent or pieces broke off.. I tried it anyway thinking maybe a could save some $, of course i didnt have spark. I installed a different whole set up from my buddys that ran perfect, but i still have no spark. If anyone has maybe a ohm chart for the stator would be great.
    There is also a riva racing programable rev limiter..
    thanks!!!!


  2. #2
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    Sweet, you have a RIVA CDI, huh? Hopefully its still good. They do go bad sometimes.




  3. #3
    hey cutlass, thank you. This thing has riva parts all over it... could be a good thing, could be a bad thing i guess. Thanks again, i appreciate it!

  4. #4
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    post some pics. I'd like to see it.

  5. #5
    wanna sell the riva cdi? PM me

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with my new to me gp1200
    By Ryanc91 in forum Yamaha Old School Skis
    Replies: 56
    Last Post: 06-29-2014, 11:29 AM
  2. Electrical problems with a 2000 Waverunner GP1200
    By Witchwith3 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-30-2011, 03:49 AM
  3. Electrical problem with a 98 GS
    By GGG in forum 2-Stroke Performance
    Replies: 15
    Last Post: 09-11-2010, 04:31 PM
  4. Problems with my 98 SLXH 1050
    By sschoeffler in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-17-2007, 11:40 PM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •