Results 1 to 9 of 9

Thread: What speed?

  1. #1

    What speed?

    Hello! I just installed a few mods on my seadoo rxp 05 what spreed whould i run?
    x-charger
    4' air
    x-intercooler
    thruhull exh
    worx-sponsons
    valve train upgradet kit
    injectors 50lb
    riva ECU
    impeller 15/20
    opas block pro off kit
    catch can
    worx intagsgaller
    riva termostat


  2. #2
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    80 ish

  3. #3
    Nice that was the speed that i was hoping for

  4. #4
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    You may have to de-pitch the prop slightly to get your rpm where they need to be. But a bit of fine tuning and 80 should be within reach for sure.

    Were you planning on monitoring AFR's? I see you dont have a fuel pressure reg either?

  5. #5
    Yeah i have i AFR guage and a boost guage. I have heard that my setup i safe so i dont needed a reg.
    I have i fast question to where Will i mount the boost sensor?

  6. #6
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Yeh, if anything you will likely be rich. But you can determine that seeing as though you have an AFR gauge.
    On each of the runners of the inlet manifold manifold, you will see a nipple. Use a small drill to drill it out and use this as your boost reference.

  7. #7
    Okey thansk and i have ont question more i have ŕ mount for the afr sensor that i mount between the exhuase and the j-pipe but when i mount it i cant mount the j-pipe and the waterbox becuse Its no room, the charger is in the way... what is wrong?

  8. #8
    HardmanGT's Avatar
    Join Date
    Aug 2009
    Location
    Rutherfordton, NC
    Posts
    459
    +1
    3
    Quote Originally Posted by Agi94 View Post
    Okey thansk and i have ont question more i have ŕ mount for the afr sensor that i mount between the exhuase and the j-pipe but when i mount it i cant mount the j-pipe and the waterbox becuse Its no room, the charger is in the way... what is wrong?
    Post some pictures. Sounds like the bung may have been welded in a bad spot

  9. #9
    Click image for larger version. 

Name:	greenhulk.png 
Views:	72 
Size:	109.7 KB 
ID:	279017 thats the adapter that i use but i can´t install the j-pipe when i use it..

    (sorry for bad english, im from sweden)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what speeds are you getting on your rxt?
    By wavehummer in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 07-23-2013, 10:11 PM
  2. What Speed Should I be Running
    By PasTelito4u in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 06-20-2008, 08:05 AM
  3. What Speed Is Everyone Up To ?(250 X)
    By Kiwi Racer in forum Kawasaki PWC Performance (4-stroke)
    Replies: 41
    Last Post: 10-20-2007, 12:25 PM
  4. Any idea what speed I should be turning?
    By Yellow93 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-25-2006, 10:33 PM
  5. 7390 Rpms- what speed?
    By Gprran-1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 06-03-2006, 09:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •