Results 1 to 3 of 3
  1. #1

    Seadoo lost speed

    I have an 2009 seadoo rxp 215 and i lost speed. top speed went from 72 mph to 56. is it possible it could be the supercharger. any help would be greatly appreciated


  2. #2
    DustMan's Avatar
    Join Date
    May 2010
    Location
    NC
    Posts
    56
    +1
    1
    check all your hose clamps, supercharger hose for sure
    Last edited by DustMan; 07-29-2012 at 08:01 PM. Reason: .

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Pull the intake hose off, and see if the wheel spins freely, if it does, than it's toast.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lost speed WTF
    By ecpChris in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-04-2007, 07:01 PM
  2. Lost speed question on 2002 RXDI
    By sdrider in forum 2-Stroke Performance
    Replies: 16
    Last Post: 06-06-2007, 02:01 PM
  3. Lost speed sensor wheel!
    By Minx20 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-17-2007, 09:56 PM
  4. Lightened my hull... lost speed!
    By 05Limited in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 09-29-2006, 01:02 PM
  5. Found cause of lost speed
    By Sundance in forum 4-Tec Performance
    Replies: 3
    Last Post: 12-10-2005, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •