Results 1 to 6 of 6
  1. #1

    03 gtx di hi temp reading - but engine not hot

    hello,

    so i'm riding my sea doo no issues, if i have the throttle wide open, a high temp reading comes on. I turn it off check the engine and the engine is not hot. Why am i getting this error?

    thanks


  2. #2
    Bump for a newbie

  3. #3
    Blackhawk36's Avatar
    Join Date
    Apr 2012
    Location
    Maryland, USA
    Posts
    144
    +1
    1
    Check the water regulator in the exhaust. If it is malfuntioning you will get the high temp even though it isn't the engine.

  4. #4
    Quote Originally Posted by Blackhawk36 View Post
    Check the water regulator in the exhaust. If it is malfuntioning you will get the high temp even though it isn't the engine.
    Couple of questions:
    1. Is the water regulator the same as the pressure regulator?
    2. How doi know if it's malfunctioning?

    Thanks for all your help

  5. #5
    Blackhawk36's Avatar
    Join Date
    Apr 2012
    Location
    Maryland, USA
    Posts
    144
    +1
    1
    you might want to try pwctoday.com. They are more dedicated to two strokes while this site is more 4 strokes. You can download the full service manual for your ski on that site for free. It has all the info you could want.

  6. #6
    Thanks for your help I'll go there's

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. newbie with 03 GTX di, need help and clarification
    By nigel_miguel in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-30-2012, 09:06 PM
  2. 03 GTX DI firing on 1 cyl., maintenance light is on.
    By Mlj3 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-29-2012, 09:56 PM
  3. 03 gtx di - new to me keeps beeping
    By nigel_miguel in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-17-2012, 09:46 PM
  4. 03 XP DI need help burnt down engine....again!
    By barry1me in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-19-2009, 11:22 AM
  5. 03 rxdi constant hi temp warnings HELP??
    By Explorer64 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-04-2007, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •