Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2012
    Location
    Weirton Wv
    Posts
    7

    need help!1995 polaris 750 slt Electrical!

    Does anyone have a diagram or picture of the terminal board to show what wires go where?I'm not color blind lol but there empty slots on my board and just wanna make sure that its right,thx


  2. #2

    Join Date
    Sep 2011
    Location
    Ottawa, Ontario
    Posts
    79
    +1
    1
    http://www.greenhulk.net/forums/showthread.php?t=15438

    Couple of posts up in the Stickies.
    Hope this helps

  3. #3

    Join Date
    Jul 2012
    Location
    Weirton Wv
    Posts
    7
    Yeah I saw that thread but it doesn't show the terminal board and what wires go were on it,thx though

  4. #4

    Join Date
    Sep 2011
    Location
    Ottawa, Ontario
    Posts
    79
    +1
    1
    Yes it does. Post # 8 shows a close up of the terminal board. You can read the wire colours on it. You take blue wire and plug it into the electrical board where it says blu and so on.
    At least i bloody hope so, thats how i just did my board using that post.

  5. #5

    Join Date
    Jul 2012
    Location
    Weirton Wv
    Posts
    7
    Ok I got all the wires were they need to go EXCEPT there is a brown wire that coming from the cdi top box,now my terminal does not have any to plug the wire onto.any ideas?

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    That brown wire is actually referred to as "tan". There should be a T connection on the terminal board with a wire connected to it. The wires may actually be quite a different shade of brown or tan than each other, but they are both for the overheat sensor....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help! 1996 Polaris 700 slt
    By KHVETTE in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-22-2010, 03:13 PM
  2. Need help! 1996 Polaris 700 slt
    By KHVETTE in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-21-2010, 03:35 PM
  3. hard starts on 1995 polaris 750 slt
    By zakatak in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-19-2009, 11:13 PM
  4. 1995 Polaris 750 SLT "HELP"
    By Sasquach in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-09-2008, 02:26 PM
  5. NEED HELP!!! '96 Polaris 780 SLT
    By moosehead4242 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-22-2007, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •