Results 1 to 4 of 4
  1. #1

    does this look correct

    hi guys im have problems with my 185 s/c 1 engine mount has given up and some how the drive shaft is about a inch to short does this all look correct?


    its my drive shaft but doesnt look right to me?


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    looks normal...but rusty
    you can not look at it and tell if it is in correct alingment
    you will need a tool to check it

  3. #3
    ok many thanks for the reply

  4. #4
    also could 1 engine mount cause the shaft to pull from impeller?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. helmet cam...does this look like a good one
    By WATER WOODY in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 12-30-2006, 01:40 AM
  2. Before and After, Does this look...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 11-03-2006, 08:00 AM
  3. does this look ok...??
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 07-11-2006, 08:20 PM
  4. 05 pump- does this look ok to you?
    By idizzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 12-10-2005, 05:41 PM
  5. Does this look normal?
    By joeg in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-19-2005, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •