Results 1 to 6 of 6
  1. #1
    Eat-My-Roost's Avatar
    Join Date
    Jun 2012
    Location
    East Valley, AZ (Born & raised in Cali)
    Posts
    152
    +1
    1

    Only getting 7650-770 rpms...Piggyback Mod???

    Finally had a good day at the lake with my cousin Rxp Tjeeze after getting the head rebuilt & SC spring washers replaced this past Saturday. My only issue was I was getting only 7650-7700 rpms tapped out. The wear ring & impeller appear to be in good shape and I'm riding on brand new spark plugs. My cousin mentioned getting a piggyback mod? Could this be where I'm missing that 8-8100 rpm range? Thanks in Advance


  2. #2
    Eat-My-Roost's Avatar
    Join Date
    Jun 2012
    Location
    East Valley, AZ (Born & raised in Cali)
    Posts
    152
    +1
    1
    "Only getting 7650-*7700 Rpms"

  3. #3
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Piggyback mod? Scom module maybe? What ski is this?

  4. #4
    Eat-My-Roost's Avatar
    Join Date
    Jun 2012
    Location
    East Valley, AZ (Born & raised in Cali)
    Posts
    152
    +1
    1
    Quote Originally Posted by surferd15 View Post
    Piggyback mod? Scom module maybe? What ski is this?

    "Knock sensor piggyback adapter"...05 rxp...

  5. #5
    I see you are in AZ. How hot is the air temp and water temp? I am only getting 7800 RPM with water temp of 92 and air temp in the 90's. This ski was hitting 8100 in the spring.

  6. #6
    Eat-My-Roost's Avatar
    Join Date
    Jun 2012
    Location
    East Valley, AZ (Born & raised in Cali)
    Posts
    152
    +1
    1
    Quote Originally Posted by Sea Dood View Post
    I see you are in AZ. How hot is the air temp and water temp? I am only getting 7800 RPM with water temp of 92 and air temp in the 90's. This ski was hitting 8100 in the spring.
    I haven't even had a chance to ride it in AZ yet, I had it fixed out in Cali & decided to ride it out there at Lake Elsinore. Air temp has been average 105-110 degrees...This weekend I'll be in Laughlin....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 05-01-2016, 02:04 PM
  2. RXT-X only getting to 6200 rpms
    By clouless in forum 4-Tec Performance
    Replies: 8
    Last Post: 01-09-2009, 12:24 PM
  3. Only getting 6300 RPM's
    By BIGJV RXT in forum 4-Tec Performance
    Replies: 7
    Last Post: 12-29-2007, 11:29 AM
  4. Replies: 10
    Last Post: 07-16-2007, 09:37 PM
  5. HELP: only getting 7900 7950 RPM's
    By majundecid in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-16-2007, 01:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •