Results 1 to 2 of 2
  1. #1

    Battery smoking at terminal, won't crank

    I have 2006 vx110 that won't crank over. I get a click and the battery starts smoking. Tried a new battery, checked all fuses, even swapped the electrical box from an identical machine but still nothing. Any ideas?


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by truckfan View Post
    I have 2006 vx110 that won't crank over. I get a click and the battery starts smoking. Tried a new battery, checked all fuses, even swapped the electrical box from an identical machine but still nothing. Any ideas?
    If it's smoking at the terminal most likely the cable is bad were it goes in the terminal replace cables and you should be fine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1100 Waveventure smokes at idle,long crank warm
    By autowizzard in forum Yamaha Old School Skis
    Replies: 11
    Last Post: 07-15-2012, 10:09 PM
  2. 97 GTX Won't Crank
    By kocomo in forum 2-Stroke Performance
    Replies: 17
    Last Post: 08-13-2008, 07:09 PM
  3. 2006 RXT - Oil Change - Engine won't crank
    By RXTsea in forum 4-Tec Performance
    Replies: 17
    Last Post: 12-28-2007, 04:18 AM
  4. 2004 GTX Seadoo - Engine won't crank
    By Scooby101 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-16-2007, 11:01 AM
  5. '96 Polaris SL700, won't crank
    By markamus in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-01-2007, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •