Results 1 to 4 of 4
  1. #1
    forklifttechnj's Avatar
    Join Date
    Jul 2012
    Location
    atco, nj
    Posts
    8

    Thumbs down 1995 xp charging issue

    been redoing 1995 xp & gtx, all my headaches x 2. xp runs like a beast, battery light doesnt come on, checking both skis at battery with dvm when running, gtx= normal, 13.2-14.35vdc (idle to higher rpm) , xp= not much above static battery voltage, rev it up and get maybe 12.75 vdc., not enough to turn on light, low enough i dont trust it and need to correct problem, stator output(a/c) across the two yellow wires(running) is identical on both skis =19-25 vac, so supply to rectifier is not in question, dc output became suspect, so i replaced rectifier/regulator, results= 13.5 vdc @ 5000rpms, two restarts later= back to same symptom, barely charging. i ohmed each yellow wire individually to ground to check for shorts in stator, tested clean, looked at schematic, red dc + output wire out of rectifier goes into ecm, basically to go across a 15a fuse then go to hot side of starter solenoid to charge the battery back across the cable, also see it bridges over a 5a fuse to a red wire w/ a purple tracer to tattle tale to the low battery light on gauge. logic says good a/c input to rectifier, not good output=bad rectifier, after replacing it for $63.00 and same problem, , my tally on both skis= should have bought a way newer ski, ha ha, rebuilt carbs on both skis, jet pumps, wear rings, drivelines, seat covers, fuel lines and stainless clamps, blow molded fuel sender floats, tig welded head pipes, awesome pop off tester made from a bicycle pump, and one good friend from work who god gave a few extra marbles to nice enough to help me, im looking at ski, print and logic all pointing towards another rectifier, (a/c input there, also clean ground) , anybody had this symptom/similar, thanks in advance


  2. #2
    If it was an aftermarket rectifier - that is your problem.. But before you replace it again - check for battery voltage through the fuses.. They have been know the buildup corrosion and resistance.. 12 volts on one side of fuse and 10 volts on the other type thing..

  3. #3
    forklifttechnj's Avatar
    Join Date
    Jul 2012
    Location
    atco, nj
    Posts
    8
    yeah, it was aftermarket, gonna swap out from gtx known good, ill post results, thanks

  4. #4
    forklifttechnj's Avatar
    Join Date
    Jul 2012
    Location
    atco, nj
    Posts
    8
    its 8/30/12 made it to beeselys point seadoo (oem rec) $85.00 later im charging @ 14.2 vdc !!!!!!!!!!!!!!!!!!!!!!!!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 XP Issues
    By BombThreat in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-26-2013, 11:16 PM
  2. 1995 seadoo xp starting issue
    By Schaffer5103 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-27-2013, 09:29 PM
  3. 1995 xp not charging
    By forklifttechnj in forum 2-Stroke Performance
    Replies: 5
    Last Post: 08-30-2012, 04:21 PM
  4. 95 XP charging problem
    By denrxp in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-25-2007, 12:04 AM
  5. Charging issue...
    By meeper in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-30-2006, 08:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •