Results 1 to 4 of 4

Thread: pump help

  1. #1

    pump help

    hi ive just bought a new pump housing as the old one was cavitating, badly and had damaged veins im swapping the pump shaft over and the cone but after iput it back together i found the prop very tight to spin is this right?


  2. #2

    Join Date
    Mar 2006
    Posts
    1,831
    +1
    119
    no. You most likely have the bearing pinched between the thrust washer and pump shaft.

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,268
    Quote Originally Posted by jim View Post
    no. You most likely have the bearing pinched between the thrust washer and pump shaft.
    +1 likey the thrust washer is now broken, assuming of course the pump type..help us hgelp you..ID the year and engine size of your ski....

    you may also have a bent prop blade that is rubbing the wear ring, or if you installed the wear ring and it's the "secure with screw type" one or more of the screw holes aren't deep enough.

    this is why it is needed to know what ski this is from.

  4. #4
    Quote Originally Posted by nmpeter View Post
    +1 likey the thrust washer is now broken, assuming of course the pump type..help us hgelp you..ID the year and engine size of your ski....

    you may also have a bent prop blade that is rubbing the wear ring, or if you installed the wear ring and it's the "secure with screw type" one or more of the screw holes aren't deep enough.

    this is why it is needed to know what ski this is from.
    hi the ski is a 98 gtx limited the prop is free from the wear ring and the securing screws are perfect the wear ring is true.

    when the pump cone is off it spins fine as soon as i put the cone on it has resistance when i try to spin the prop

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NoOoOo! Steering Noozle/Pump Help!
    By Sabu1984 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 05-16-2008, 03:06 AM
  2. Bilge Pump help
    By jetskier90 in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 03-18-2008, 06:33 PM
  3. pump help need now
    By bajaeater in forum Yamaha PWC Performance (2-stroke)
    Replies: 31
    Last Post: 01-26-2008, 12:00 PM
  4. Need to replace the pump. HELP
    By Alex Speedster 200 in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 09-12-2007, 02:50 PM
  5. More ext pump help please
    By novanuttz in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-03-2007, 02:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •