Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    Do work son ultra150nc's Avatar
    Join Date
    Apr 2008
    Location
    Charlotte
    Posts
    235

    Mini-Rude Leaking Air At Spacer?? (PICSS**)

    Hey Guys,

    I've have a boost leak for a while now, only running 9-10 psi ( I've seen 12-13) and its been hard to tune because of that.

    Also my boost gauge is always spiking and never consistent, Ive ruled out the gauge and hookup.

    When I send 5-7 psi back into the system from the reference line for the RRFPR and have the S/C blocked off at the front housing and throttle at WOT the seal bubbles all along the spacer.

    The blower was built by Jerry 25 hours ago with a rude kit.

    One member said pull the charger and re silicone the spacer, however he had never seen this before.

    My concern is I was only putting 5-7 psi into the intake, I/C, piping, S/C.. when it should hold 14 psi all day.. Is my diagnoses wrong? Should I pull the blower??

    http://[img]http://www.greenhulk....jpg[/img]

    .Click image for larger version. 

Name:	S:C.jpg 
Views:	263 
Size:	71.1 KB 
ID:	279288


  2. #2
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,353
    +1
    970
    I'm chasing a similar situation.......boost gauge showing a max of 11-12 psi.

    If you suspect the seal is leaking pull the charger and fix it!

    What boost gauge are you using?

  3. #3
    Do work son ultra150nc's Avatar
    Join Date
    Apr 2008
    Location
    Charlotte
    Posts
    235
    Quote Originally Posted by 1tommygunner1927 View Post
    I'm chasing a similar situation.......boost gauge showing a max of 11-12 psi.

    If you suspect the seal is leaking pull the charger and fix it! Yeah thats what another member said, I just want to make sure it won't screw it up.

    What boost gauge are you using?
    Auto-lite by Auto Meter, I sealed it up in the back. I also run water temp and A/F

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Time to check the charger slip, may need a shim.

  5. #5
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,353
    +1
    970
    Have you checked the slip? I checked mine at 25 hours and again at 60 hours. 16 ft/lbs.

    I have the Pro-Comp AutoMeter gauge and matching oil/water temp gauges. The A/F gauge is the MTX-L. I'm going to replace the boost gauge with the Innovate boost gauge soon. Last time out all I saw on the current boost gauge is about 9 psi. And, the S/Cer has a little over 80 hours on it....time for a rebuild.

  6. #6
    Do work son ultra150nc's Avatar
    Join Date
    Apr 2008
    Location
    Charlotte
    Posts
    235
    Quote Originally Posted by psycho rxp View Post
    Time to check the charger slip, may need a shim.
    checked its ok,

  7. #7
    Do work son ultra150nc's Avatar
    Join Date
    Apr 2008
    Location
    Charlotte
    Posts
    235
    The slip is ok I checked it before I sealed everything off and put air into the system.

    Lets just say it did slip (its not) it still shouldn't leak air from the spacer correct??

    I'm just thinking out load..

  8. #8
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,353
    +1
    970
    That's right, it shouldn't leak from the spacer.

  9. #9
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,061
    +1
    790
    Very easy fix. Pull the SCer for a inspection. Remove the front houseing and spacer. Clean Both sides of the spacer and both halves of the SCer. Reseal it all back up and torx bolts to 89inch lbs. I use a very thin amount of ultra black on both halves of the SCer, so when it reseals the spacer has a amount on boths sides.

  10. #10
    Do work son ultra150nc's Avatar
    Join Date
    Apr 2008
    Location
    Charlotte
    Posts
    235
    Quote Originally Posted by Water4fire View Post
    Very easy fix. Pull the SCer for a inspection. Remove the front houseing and spacer. Clean Both sides of the spacer and both halves of the SCer. Reseal it all back up and torx bolts to 89inch lbs. I use a very thin amount of ultra black on both halves of the SCer, so when it reseals the spacer has a amount on boths sides.
    ok sounds good, have you ever seen this before??

    Ive pulled the charger so Ill go do that now..

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mini Rude or Engine Tech Wheel & Spacer
    By Glade Rider in forum 4-Tec Performance
    Replies: 111
    Last Post: 06-27-2011, 11:14 AM
  2. middle carb leaking gas at idle
    By ucf_motorcycle in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 07-20-2009, 01:30 PM
  3. ultra 150 leaking oil at the pump ring
    By vlad in forum Kawasaki How To & FAQs
    Replies: 7
    Last Post: 07-19-2008, 09:46 AM
  4. carbs leaking air?
    By xlint89 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 04-20-2008, 10:30 AM
  5. leaking air?
    By Pale Rider in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-24-2007, 03:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •