Results 1 to 3 of 3
  1. #1

    94 Yamaha GPIII 750 runs for 20-30 minutes then bogs out any ideas?

    My buddy has a 94 Yamaha GPIII with a 750 CC . starts fine on the trailer and only runs good for 20-30 minutes before bogging out. New head gasket, fuel pump, plugs, ect. any help would be great.


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by rabiddawg View Post
    My buddy has a 94 Yamaha GPIII with a 750 CC . starts fine on the trailer and only runs good for 20-30 minutes before bogging out. New head gasket, fuel pump, plugs, ect. any help would be great.
    make sure there is no settlement on the bottom of the tank or a clogged fuel filter.

  3. #3
    I had the same problem and it turned up to be the one way valve on the fuel line. The check valve is a one way valve that only allows fuel to go in one direction. It was clog and it was only allowing limited fuel supply when in high gear. This happened to me with a boat and not a Pwc but the concept should be the same. Also. I am not familiar witw fuel pumps in pwcs but if they are mechanical fuel pumps instead of electric that can create a problem when they get hot as the diaphragm becomes hot and it becomes soft on a faulty and old pump. Also, have you check the engine temperature when starts to bog down? If the engine is getting to hot the engine will behave erratic and lose power. I can only think that you have a fuel problem or temperature problem. I hope this helps. Let me know

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bogging after running for 20 min
    By Jadobmeier in forum Polaris Tech Tips and Info
    Replies: 0
    Last Post: 07-30-2016, 06:38 PM
  2. 94 Polaris SLT 750 Running Sluggish
    By b blake in forum Polaris Projects
    Replies: 3
    Last Post: 07-09-2013, 09:49 PM
  3. 2000 millenium edition gtx, fi. runs for an hour and then dies!
    By Alex3012red in forum 2-Stroke Performance
    Replies: 20
    Last Post: 01-14-2011, 10:20 AM
  4. Replies: 1
    Last Post: 10-13-2010, 11:23 AM
  5. GP 800 runs good for a few minutes - then dies
    By darrengee in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-12-2009, 01:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •