Results 1 to 3 of 3
  1. #1

    Pump issues - 07 R-12x

    My Honda is a 2007 model R-12x, but I purchased it brand new two summers ago.

    It has been making a deep loud sound that just started. Sounds like a hole in the muffler.

    I took it in to Honda today and they stated that the seals in my pump are bad. I only have 35 hours on this ski and have taken good care of it. Garage kept, never below freezing temps, etc. Performed the factory maintenance. Used Honda parts, oil, etc.

    I asked why the seals went out so quickly and they said "wear and tear". Really? After 35 hours?

    Anyone else have this issue? If so, what's the real issue here? What caused it? How do I avoid it?

    I am still waiting to find out how much they are going to charge to fix it.

    Craig C.

  2. #2
    john07ex's Avatar
    Join Date
    Jul 2007
    Orlando, Fl
    Yes it is a KNOWN issue and many are fixed under warranty.
    Even if its OUT of warranty..

    Keep it lubed..there is a fitting just under the rear seat..waterproof grease

  3. #3
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Jax, Florida
    There are many of us that have gone over 500 hours on the same pump bearings. Most of the failures have been due to incorrect assembly [sometimes from the factory].
    It should be under warranty, it is up to your dealer, not Honda as to whether it is covered.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts