Results 1 to 5 of 5

Thread: 04 Rxp RPMs

  1. #1
    Biggsw784's Avatar
    Join Date
    Jul 2011
    Location
    Wichita Falls Texas
    Posts
    181
    +1
    1

    04 Rxp RPMs

    I have a 04 rxp with 240 hrs and when I bought it the prop and wear ring was wore smooth out. I installed a new ring and brand new solas 14/19 to it. After doing that, my rpms were at 7450. I don't know what rpms were before with the stock prop because I bought it as is with it cavatating very bad. The engine was bone stock at the time also. I bought the 14/19 prop with intentions of adding performance parts. My buddy bought a 04 rxp with 18 hrs on it and he also added the 14/19 prop and he is pulling about 7750. I dont understand why his pulls about 300 rpms more?? So last weekend I installed a riva power filter kit and a riva free flow exhaust with a through hull tip. I figured if my ski was being held down because of power that these together should give me a few hundred rpms Well I took it out today and those upgrades did absolutely nothing besides the loud supercharger whine and the exhaust sounds like a crouch rocket which I do like that. Anyways I am at a lose. What could cause this?? I am going add a x charger , external intercooler, rrfpr and 42# injectors this winter but would like to figure out what's up with what I have going on. The supercharger has been rebuilt once at 130 hrs and it has 110 hrs on this build but I wouldn't think it would keep the rpms down a few hundred would it?? Could valve springs cause this?? Not sure how long they last?? Never have changed the plugs which I have only rode it about 10 hrs so not sure how old they are?? This thing runs really good out of the hole but just not getting rpms. When it comes out of the water it hits the rev limiter so I know the motor will hit it. Any help here is appreciated.


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    charger slip is probably low. U should rebuild it every 100 hrs anyways.

    May also need to depitch the prop after your charger slip is checked to get 8100 rpms.

  3. #3
    Biggsw784's Avatar
    Join Date
    Jul 2011
    Location
    Wichita Falls Texas
    Posts
    181
    +1
    1
    yea i was hoping it wasnt anything to do with the supercharger since i am going to just buy a new x charger. i was hoping to make it through the summer. is there anything i can do to check the slip or is that something out of my hands?? thanks man

  4. #4

  5. #5
    Biggsw784's Avatar
    Join Date
    Jul 2011
    Location
    Wichita Falls Texas
    Posts
    181
    +1
    1
    thanks again man

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low RPM 7700 and Top Speed 70 with S3 and C5 SC's on 04 RXP
    By snowrunner in forum 4-Tec Performance
    Replies: 24
    Last Post: 06-23-2009, 08:54 AM
  2. 04 RXP Turning 7700 RPM?
    By snowrunner in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-14-2007, 12:13 AM
  3. 04 RXP RPM loss/ Ride Style
    By ferny1usmc in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-06-2006, 10:24 AM
  4. 04 RXP RPM Numbers Dropping!!!
    By rxpman100 in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-06-2005, 06:33 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •