Results 1 to 8 of 8
  1. #1

    93 750 sl stator in a 94 650 sl hull

    I just changed the motor in my 94 650 sl ski to a 750 motor out of a 93 750 sl ski. I was able to wire the 93 750 stator into the black box of the 650 sl and the ski runs and idles great and will rev just fine out of the water. When I put the ski into the water it idles with no issue, but as soon as I touch the throttle the ski dies. It doesn't stumble or anything, just shuts right off. Not sure if the change in stators is causing the issue, or if my fuel mixture is too rich. I still have oil injection but also put a 40:1 mix in the fuel tank. Thanks


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Welcome to the Hulk. There's so many variables going on with this it's going to be hard.


    1. Was the engine you bought a good running engine?

    2. What's the compression?

    3. Have the carbs been serviced?

    4. What's your fuel pressure at idle and WOT?

    5. What are the carb screws set at?

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    So you are using a 750 stator with a 650 electric box/CDI? May have some compatibility issues there. Xlint knows more about that sort of thing.

  4. #4
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    My understanding (have no actual experience) is that the 92/93 stators and CDI's were different (referred to as analog) and were not interchangeable with 94+ parts.

    This may be your issue unless you are using the 93 CDI as well.

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    93 750 used an analog CDI as well, so any 650 SHOULD be compatible with it.

    He needs to know if the engine he bought was in GOOD condition first.

    As we all know, and engine can run on land very well, but put it in th water and have all sorts of issues.

  6. #6
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Quote Originally Posted by xlint89 View Post
    93 750 used an analog CDI as well, so any 650 SHOULD be compatible with it.

    He needs to know if the engine he bought was in GOOD condition first.

    As we all know, and engine can run on land very well, but put it in th water and have all sorts of issues.
    He is running a 93 Stator in a 94 ski with presumably a 94 CDI....

  7. #7
    Both 93 750 and 94 650 use an analog input from stator, and the ski does run fine out of the water. The motor is coming off a fresh rebuild with new pistons and rings, have good even pressure on all three cylinders. I did not rebuilt the carbs, but the ski they came off was running fine. The fuel pressure is good and none of the cylinders are running lean with 3 output fuel pump. I am wondering if the timing is the problem, the 750 fires at 18 degrees before TDC and 650 fires at 16 degrees before TDC, not sure if that would cause the issue, but could be since as soon as I touch the throttle to rev past idle, it dies instantly with no sputtering.

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    I doubt timing is the issue. Xlints questions are still valid and have not been answered:

    What's the compression - What are the actual values, not just "good even pressure"

    A ski "running fine" is not a valid reason for not rebuilding the carbs. What is the pop of pressure of the carbs?

    What's your fuel pressure at idle and WOT?

    What are the carb screws set at?

    How do you know none of the cylinders are running lean? Installation of a 3 outlet pump doesn't instantly mean you are not running lean....

    What does your piston wash look like?

    What jetting do your carbs have?

    Dies instantly at WOT = Lean in my book.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 93 750 sl project
    By honda123 in forum Polaris Projects
    Replies: 3
    Last Post: 08-22-2014, 11:27 AM
  2. 93 750 sl to 94 slt engine swap
    By finnegan in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 11-29-2012, 02:33 PM
  3. 1994 sl 750 wire harness in a 94 sl 650???
    By Carguybri in forum Polaris Projects
    Replies: 7
    Last Post: 07-26-2012, 11:16 PM
  4. 93 polaris 750 SL stator work in 95 polaris 750 SLT?
    By g_magic_tsp in forum Polaris Projects
    Replies: 4
    Last Post: 06-11-2011, 07:25 PM
  5. FS 93 750 sl impellor
    By bowsniper in forum Polaris Classifieds
    Replies: 0
    Last Post: 09-19-2010, 01:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •