Results 1 to 10 of 10

Thread: Slow rxp

  1. #1
    skingelo's Avatar
    Join Date
    Apr 2012
    Location
    Ontario
    Posts
    79

    Slow rxp

    My buddy picked up a 05 rxp. It was stock and came with a old charger with ceramics.. Before he rode it we threw on my stock charger that has brought my ski to 72.. We gps'd his ski and he got a top of 62 at 8100. We are concerned about that speed and wondering where we should start looking.


  2. #2
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,509
    +1
    234
    Where's the ski? Ill look at it this weekend if you want

  3. #3
    skingelo's Avatar
    Join Date
    Apr 2012
    Location
    Ontario
    Posts
    79
    Here in town.. We can get him to bring it over today if u want.. Wee still doing the sending unit on the xp?

  4. #4
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    The RPMs look good, I would start with checking the impeller and wear ring.

  5. #5
    skingelo's Avatar
    Join Date
    Apr 2012
    Location
    Ontario
    Posts
    79
    Quote Originally Posted by DaveC View Post
    The RPMs look good, I would start with checking the impeller and wear ring.
    Yes my first thought was wear ring.

  6. #6
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,509
    +1
    234
    Ill txt in a bit... Ill check it out could even be charger slipping .. But so many variables can come into play .. Ill check it... Make sure that xp has no gas in it !

  7. #7
    skingelo's Avatar
    Join Date
    Apr 2012
    Location
    Ontario
    Posts
    79
    Quote Originally Posted by greenbullet View Post
    Ill txt in a bit... Ill check it out could even be charger slipping .. But so many variables can come into play .. Ill check it... Make sure that xp has no gas in it !
    Ok.. Charger could be slipping, like I said though that charger brought me to 72 and a buddy to 73 just before I took It off. Your right though, worth checking.

  8. #8
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,509
    +1
    234
    Ill txt in a bit... Ill check it out could even be charger slipping .. But so many variables can come into play .. Ill check it... Make sure that xp has no gas in it !

  9. #9
    skingelo's Avatar
    Join Date
    Apr 2012
    Location
    Ontario
    Posts
    79
    Alright

  10. #10
    Flynlow's Avatar
    Join Date
    Sep 2010
    Location
    Malvern, Arkansas, United States
    Posts
    60
    Prop and wear ring is what I would look at. When I bought my 06 this summer the prop had a couple of small dings and the wear ring was trash. Went from 66 to 69.5.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. can anybody shed any light on this slow rxp
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 12
    Last Post: 04-19-2010, 08:29 AM
  2. Please Help Slow Rxp
    By walt kay in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-21-2008, 10:42 AM
  3. slow RXP
    By mustang5x0 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-16-2008, 04:21 PM
  4. Slow RXP?
    By JimC in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-08-2007, 02:53 PM
  5. Slow RXP Riva Stage 2
    By idizzy in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-13-2006, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •