Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Polaris virage txi a lot of problem, please help

    Hi guys, I have a 2001 polaris virage txi with a lot of problem, I will like to get it back to life.
    Two major issues:


    Hard to start, always have to use starting spray in air filter...

    New reverse motor stopped working...
    the pivot must turn on to the left side but it went to the right, there is not enough space in that way and the rectangular bar was locked with the fibreglass of the hull, it caused that the reverse doesn't work any more and now I have a red light blinking and a reverse sign in the dash board, what should I do? do I have to replace the reverse again? Why it went to the right side insteAd to the left?
    Please help


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,514
    +1
    1,258
    first off..using starting fluid is really really dangerous..get a squirt can with a little premix in it instead. Starter fluid burns so hot you'll damage your exhaust hoses and maybe yourself if you spray a little too much in there.

    the entire reverse motor system is all too complicated with lots of switches and cams in the box. you likely installed the control arm backwards. Take the arm off, set to forward and reinstall the arm opposite of what it was.

    the box is a bit tough to get off first time..but it will come off ( be ready for some pain) Pulling the jet pump makes the work of getting the bolts out a bit easier.

    The start problem could be a number of things, including having the throttle body misset. How's the idle speed in the water?..

    Explore/search for polaris tips and tricks ..you have plenty of reading to do before you can start to tr to really fix the starting issue, but get off that starter fluid right now!

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Hard to Start; I would be suspecting low injector voltage, but it could be a bunch of other things too.

    See my signature links for some Ficht diagnostics and more info.

  4. #4
    I guys, thank you for reply

    I have removed the reverse already, the arm was placed correctly, the issue here is that the reverse is placed a little bit to the right, (by the way I bought this reverse form ebay because the mine was rusted) and there is only enough space on the left of the hull and the new one installed have moved to the right and was stopped for the hull.

    (See the drawing attached)..

    now with the reverse in my hand it doesn't move any more and I have a red light blinking with a reverse as a sign, do I have to reset something?

    I sent the reverse back to the seller and he said that is working...

    Click image for larger version. 

Name:	CCE08102012_0000.jpg 
Views:	56 
Size:	23.1 KB 
ID:	280093

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Polaris made more than one version of the PERC electric reverse motor.

    One version mounts to the side of the hull under the seat, and has a cable that runs back to the jet pump.

    Another version mounts the reverse motor right on the pump tunnel and uses a more direct linkage to the jet pump. This is the type that I think your 2001 Virage TXi uses.

    Which PERC motor version did you buy, from what model and year Polaris?

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Click image for larger version. 

Name:	ImageUploadedByTapatalk1344623771.488932.jpg 
Views:	49 
Size:	65.3 KB 
ID:	280094

  7. #7
    yes, it is the same,, actually I have compared with mine and looks equal
    ,, that is why I'm worry about the wrong turn.

  8. #8
    maybe I can figure out a solution (with a shorter arm) if at least I can make the reverse work again doesn't matter what way it take

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Did you take apart the original reverse motor?

    There is a complex set of switches and cams that control how the motor moves and where it stops. If the mechanism has been put back together incorrectly it will not work properly.

    Since the arm was jammed against the hull there may be damage inside the gearbox.

  10. #10
    when I installed this one, worked two times well but the third one changed the turn to the right

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 42
    Last Post: 08-10-2015, 02:42 PM
  2. 2002 Virage 1200 TXi - first post and problem PLEASE HELP
    By husky9 in forum Polaris Open Discussion
    Replies: 213
    Last Post: 05-17-2015, 03:45 PM
  3. Please help with my 2002 Polaris Virage TXi check engine code
    By Dan416 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-25-2011, 05:08 PM
  4. 2001 polaris virage txi stalling/starting problem
    By 2000 gtx rfi in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-01-2011, 09:36 PM
  5. 2001 polaris Virage TXI 1200 Stutters and lacks power HELP!!!!
    By 1_kwik_virage in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-02-2010, 04:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •