Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Gp1300 shutting off

    Hello everyone, today I took my 2003 gp1300 out and I ran into some issues. I got on the ski and took off at full throttle when suddenly the ski lost power and shut off. I took off the seat and inspected the engine compartment and everything looked fine, the only thing I noticed is the the exuast the engine head were semi hot. About 1 minute after it shut off I tried starting it and it started fine I took off again and about 20 sec of wop the ski again shut off again, so I decided to go back to the dock and take out of the water. The jet ski has a stage 1 riva kit, d plate etc, and never had any issues before. I hooked the ski up to the hose and it ran fine the exhaust pipe and cylinder were both cool and water pissers were working. I checked the water strainer and it was not clogged . Any help or info is greatly appreciated.


  2. #2
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    How's the compression

  3. +1 by:


  4. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Once it shuts off did you try to start right away and see if the engine turn over, If not you had an engine seizure and most check compression.

  5. +1 by:


  6. #4
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    Once it shuts off did you try to start right away and see if the engine turn over, If not you had an engine seizure and most check compression.
    plus one

  7. #5
    Actually the 2nd time after it shut off I did try to start and it did but wasn't running right and turned off again so I gave it a bit of gas and started it again and it ran. I did not check the compression

  8. #6
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,579
    +1
    87
    maybe oil pump......

  9. #7
    What is the proper precedure of doing a compression test. I read prior posts and some mentioned the the power valves must be closed, how will I know when the power valves are closed or open? Or what is the correct procedure of closing the power valves when doing a compression test.

  10. #8
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,579
    +1
    87
    take off the the spark plug wires and then take the spark plug off and do the test one by one...

  11. +1 by:


  12. #9
    Is there any riders from north jersey that are mechanically inclined that can help me with this boat or does anyone know of a good mechanic that I can take it to that won't charge me an arm and leg in the in this area? Any help is appreciated.

  13. #10
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,579
    +1
    87
    Quote Originally Posted by Turboman1982 View Post
    Is there any riders from north jersey that are mechanically inclined that can help me with this boat or does anyone know of a good mechanic that I can take it to that won't charge me an arm and leg in the in this area? Any help is appreciated.
    pm you

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Newbie Question - MFI panel won't shut off
    By bslus in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-05-2008, 09:00 AM
  2. HELP - R12x Shuts Off and adjust Idle Question
    By tomasga in forum Honda How To & FAQs
    Replies: 5
    Last Post: 06-21-2007, 08:55 PM
  3. What causes ski to shut off/cut out?
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 05-28-2007, 03:43 PM
  4. Help! Pulse line and fuel shut off ??????
    By lodough780 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-24-2007, 04:59 PM
  5. Problem rxp keeps on shutting off
    By asiansurfer7285 in forum 4-Tec Performance
    Replies: 21
    Last Post: 12-12-2005, 11:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •