Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1

    07 ultra 250x hesitation question

    Hello, Just uncovered my 07 250x and put in new plugs. The ski previously last year had a new supercharger installed, cylinders, pistons and rings. Cold compression was about 145 even on the cylinders. She starts right up but notice that I have some hesitation from time to time. Like you take off then rpms will drop a thousand or two then pick back up. I dont know if I have valve sticking lossing compression for a brief second or what? any ideas what would cause this? I have no check engine light. Only ran it for about 15 minutes so I might just run it around for awhile tomorrow and maybe get lucky and have it clear itself. But if anyone else has an idea I would love to hear it. Speedo is not working as it seems to be topping at 40mph but feels like I am going much faster then that. Any thoughts on what the problem could be?
    Thanks,
    Jesse


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Get a gps to record speed.
    Look at the rpm while riding at WOT and see what that is
    Check sc belt tension
    Check your plug wires
    Check your air intake air horn is not stuck to the hull
    Did you upgrade your pump to the 2011 spec ? If. Not do that now.

  3. #3
    Did not gps but still low 40 maybe 50 sometimes, rpms at wot are 6000 to 6300, sc belt is tight, wires look good, dont know what the air intake horn is? Any thoughts? Throttle cable does move butterfly valve all the way open.

  4. #4
    Took the kids tubing with this today and that did pretty good at 20mph. I dont know if the gauges are reading correctly? Afterwards, did try full open throttle with and extra 350lbs of people on it and was topping at 43mph and 6400 rpm. I have no idea if it was faster then that but felt quicker then 43mph. The hesitation/bogging has slowed down and does not happend at low speed. Guess I might have to just gps it or run side by side with another ski to see how it does. It does suck down some gas quick! But if anyone has any ideas on what to check incase there is a problem I would to hear it.

    Thanks,
    Jesse

  5. #5
    Regapped plugs, tightened one hose off the supercharger that I could feel a little air from. GPS @ 49 to 50 MPH gauge is reading 45 to 46mph. Gauge reads about 6400 to 6500 RPM. Dont know where I am loosing the top end speed. It will hit 6500 rpm out of the hole but never go any faster. Looks like I was getting around 10lb of boost on the gauge.

  6. #6
    Not the air horn either, moved that and it popped off so I tested without it just to be certian. Still 6300 to 6500 rpm max, top speed gps is 50 max. Any other thoughts?

  7. #7
    Another quick note, if you race it for a second out of the water it has not problem going over 8000rpm

  8. #8
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Do a leak down test.

    With it on the hose jiggle each plug wire if you get a zap you have a bad plug wire
    Other then that if only 10 psi you may be loosing some boost somewhere as well. Loose hose bov etc.

  9. #9
    Im at work now but my dad is going out to hopefully pull the intercooler to verify it has no oil it as I heard that could be the cause. The other day we bought the regular plugs but I also heard they might only work good for one time then 50mph might be the max you get out of it. Going to order the expensive plugs again, PMR9B and see what that does.

  10. #10
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by Jessie00721 View Post
    Im at work now but my dad is going out to hopefully pull the intercooler to verify it has no oil it as I heard that could be the cause. The other day we bought the regular plugs but I also heard they might only work good for one time then 50mph might be the max you get out of it. Going to order the expensive plugs again, PMR9B and see what that does.
    What u mean by reg plugs.ngk cr9eix are just as good and half the price intercooler is not your issue

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 ultra 250x crank case question??
    By bignig in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 09-24-2010, 04:02 PM
  2. 07 Ultra 250x throttle housing bracket recall
    By XRIDER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 07-09-2008, 12:25 PM
  3. 07 Ultra 250x for sale
    By Edski in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 05-28-2008, 04:21 PM
  4. 07' Ultra 250X Replaced by 2007 RXT (Stg II+)
    By Ultra Junkie in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-14-2007, 05:08 PM
  5. Ultra 250x muffler question?
    By XRIDER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 04-13-2007, 08:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •