Results 1 to 8 of 8
  1. #1
    TURBOGTX's Avatar
    Join Date
    Dec 2010
    Location
    Cayman Islands
    Posts
    79
    +1
    1

    Question for the experts: I did some prop testing turbo and supercharged bikes

    Tested two different skis 2012rxp hull with 06 supercharged motor and 2011 RS-260 TURBO with old style shoe and pump. The 2012 had a 14/18 with a 84mm venturi turning 8500rpms 70.3mph gps @ 15psi big charger.
    The turbo on the otherhand had a 15/25 with a 81mm ring turning 8450rpms 78.5mph @ 21psi GT30/76. both had 3 blade props
    Does those figures sound normal?


  2. #2
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Something is off. Both those skis should be easily over 80MPH

  3. #3
    TURBOGTX's Avatar
    Join Date
    Dec 2010
    Location
    Cayman Islands
    Posts
    79
    +1
    1
    On the 260turbo I also tried a 4 blade 15/22r and it was all over the limiter which was set to 8600rpm (Autronic ECU) and could only manage to go 72mph!!!

  4. #4
    TURBOGTX's Avatar
    Join Date
    Dec 2010
    Location
    Cayman Islands
    Posts
    79
    +1
    1
    few photos...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	shoe4.jpg 
Views:	42 
Size:	111.3 KB 
ID:	279684   Click image for larger version. 

Name:	shoe3.jpg 
Views:	51 
Size:	91.0 KB 
ID:	279685  

  5. #5
    Autism Speaks. Its Time To Listen gOt BoOsT's Avatar
    Join Date
    May 2011
    Location
    Cali
    Posts
    1,413
    +1
    51
    speeds sound too slow for sure...what are you injecting before the turbo?

  6. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    you need to bump the limiter up to 9,200, to run the 15/22 4 blade. May try turning down the boost then.

  7. #7
    TURBOGTX's Avatar
    Join Date
    Dec 2010
    Location
    Cayman Islands
    Posts
    79
    +1
    1
    Quote Originally Posted by gOt BoOsT View Post
    speeds sound too slow for sure...what are you injecting before the turbo?
    thats the breather hose from the catch can, it keeps the salt spray off the billet wheel

  8. #8
    TURBOGTX's Avatar
    Join Date
    Dec 2010
    Location
    Cayman Islands
    Posts
    79
    +1
    1
    Quote Originally Posted by psycho rxp View Post
    you need to bump the limiter up to 9,200, to run the 15/22 4 blade. May try turning down the boost then.
    remember I ran 78mph with the 3 blade @ 8450rpm solid and the 4 blade couldn't stay loaded doing 72mph so moving the rev limit to 9.200 wont help the 4 blade at all. I plan to pitch the 3 blabe some more then move up the rev limit to about 9.000 and crank the boost up to about 25psi

    it would also defeat the purpose of having all that work done to the race ski which I tuned to 30psi only to run 21psi

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question for the experts....IC set up!!!
    By javimuni in forum Yamaha Projects & Build Threads
    Replies: 2
    Last Post: 07-01-2015, 12:33 AM
  2. 04 FX HO Rebuild question for the experts
    By ncdoo in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 11-20-2011, 08:44 PM
  3. Question for the prop bending guru's
    By Green Hulk in forum Yamaha PWC Performance (2-stroke)
    Replies: 112
    Last Post: 12-03-2009, 02:58 AM
  4. Question on nozzle size for the experts
    By engineermike in forum 4-Tec Performance
    Replies: 19
    Last Post: 02-24-2008, 02:27 PM
  5. Rude question for the experts
    By skoepp in forum 4-Tec Performance
    Replies: 15
    Last Post: 02-12-2008, 01:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •