Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2012
    Location
    minnesota
    Posts
    4

    03' msx 140 ho no spark no fuel to cylinders

    I have a msx 140 ho. I bought it two years ago for real cheap. The guy I bought it from said the EMM was out of it and needed a new one. I tinkered around with it and with info from the green hulk forum unplugged the TPS and it started right up plugged TPS back in no problem for two years. Just this past weekend it died out on the lake. No spark no fuel. Checked the ohms to CPS 149. Checked voltage to injectors while cranking over 24.6. Any one who may have any info that could help me further would be great.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Fuses?

  3. #3

    Join Date
    Aug 2012
    Location
    minnesota
    Posts
    4
    Yes the 2 and the 15's are good. Also battery when cranking is over 10.7 volts. I have the voltage I need at the injectors yet cylinders are dry. If the fuel pump is out would there be any reason that would stop spark?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Fuel pump is not connected the wire harness?

    I think the EMM does monitor for electrical presence of the fuel pump, so it might be possible that without a fuel pump connection the EMM does not even try to start the engine (no spark).

  5. #5
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    I've seen a bad tps cause no fuel pump, no spark, and no injectors. did you try unplugging it again?

  6. #6

    Join Date
    Aug 2012
    Location
    minnesota
    Posts
    4
    Fuel pump is hooked up. Unplugged tps several times. I have power to the injectors 24-25 volts. Im going the check the volts to the fuel pump next. Do I check the volts to the fuel pump while cranking over.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Fuel pump should always have full battery power.

    The Ficht fuel pump is activated by the EMM grounding the Brown wire from the fuel pump.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. no fuel to cylinder
    By 99xp in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-31-2014, 11:26 AM
  2. 03 MSX 140 no power
    By JeepMann in forum MSX/Matrix
    Replies: 15
    Last Post: 08-17-2012, 03:37 AM
  3. 03 msx 140 HO starts and stalls
    By joshfish in forum MSX/Matrix
    Replies: 2
    Last Post: 07-29-2011, 06:11 PM
  4. [email protected] 03 msx 140 no start
    By b&v in forum MSX/Matrix
    Replies: 3
    Last Post: 07-11-2010, 08:58 PM
  5. '03 msx 140...deal? or no deal?
    By fastexas in forum MSX/Matrix
    Replies: 8
    Last Post: 11-14-2007, 02:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •