Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    837
    +1
    127

    FZR w/GIO and Slow Acceleration-Related?

    I hesitate to post this because I don't want to start a bash fest against Yamaha but here goes. I bought a '12 FZR new and it has never run as well as my '09 FZS. The oil level rises because of fuel contamination (about 1/2 qt in 6 hours) and it accelerates "slower" than I think it should. The two situations where the engine lays down are-1) when the engine is not heat soaked it hits the rev limiter out of the hole for an instant, drops about 200 RPM and the boat speed climbs; once the engine is hot it drops about 500 RPM, and 2) during hard cornering (I have Macc sponsons and an R+D plate on it) the engine speed drops to about 7,000 RPM and accelerates slowly out of the turn.

    My dealer and Yamaha techs have studied the boat and performed a compression test, leak down, injector test and whatever else YDIS specifies and can find nothing wrong.

    I have two theories: 1) the rings/pistons/cylinder bores aren't true or are defective which causes a loss of cylinder pressure under high loads, and 2) the ECU is flaky or incorrect causing an extremely rich air/fuel ratio.

    I'm not mad at the manufacturer as I think most riders wouldn't even notice the effects and I am not averse to tearing the engine down for measurements and inspections but I would like to assess the probability of finding anything before I go ripping it apart. What do you guys think?


  2. #2
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Have the dealer swap it out for a new one.

  3. #3
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,567
    +1
    4,784
    Take it to a different dealer.
    I can tell you for a fact that some of them don't know jack.
    And I would definitely get a second opinion before "ripping" anything apart.

  4. #4
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Quote Originally Posted by pro1200 View Post
    The oil level rises because of fuel contamination (about 1/2 qt in 6 hours) and it accelerates "slower" than I think it should.
    My advise would be take to another dealership... if not an option talk to the head mechanic there ask him if the oil level should go up with time (he will tell you no) than ask him if he would mark your dipstick level for you and you will bring it back in after a few hours of riding for him to inspect.

  5. #5
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    also you sure you dont have a stuck injector or something? How do your plugs look?

  6. #6
    Kelly_A's Avatar
    Join Date
    Dec 2009
    Location
    Central Oklahoma
    Posts
    660
    +1
    17
    Any mods at all on your '12?

  7. #7

    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    394
    +1
    11
    Most likely bad valves or rings! When they did the leak down test, did they tell you the percentage that it leaked? Was it low, moderate or high? I would ask them to do it again and take a look at the gauge for yourself!

  8. #8
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Quote Originally Posted by kansasgpr View Post
    Most likely bad valves or rings! When they did the leak down test, did they tell you the percentage that it leaked? Was it low, moderate or high? I would ask them to do it again and take a look at the gauge for yourself!
    would you not think he would be loosing oil than? expecially if it is bad enough that you can feel HP lose..

  9. #9

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    837
    +1
    127
    The boat is totally stock. I plan on doing level one mods once I get these issues resolved. I asked the tech how the leak down test was performed and he said he just did what the YDIS diagnostic software specified. A rep from Yamaha was in the shop when my boat was there and the first thing he suggested was an injector test. They only checked whether they fire when power is applied. I don't think that tells much because the the performance could be different at high RPMs. I don't understand the phenomena of GIO-how can gas end up in the oil after it has been through the combustion process? If the gas is getting past the rings I always thought this indicated blow by in the cylinder which would pressurize the crankcase and cause oil to be displaced into the intake system.

    I am entertaining the idea of taking it to a different dealer but I have to figure out how to assess the skills of the techs before I select one. As I said before, this effect is very subtle. I have a tendency to see problems when there really aren't any so the acceleration issue may be cured with level one mods but I can measure the increase in oil level so I'm convinced this is indicative of a defect of some kind.

  10. #10
    Avi8tor's Avatar
    Join Date
    May 2012
    Location
    Greenville, NC
    Posts
    826
    +1
    27
    DO you smell strong contamination of gas in your oil?
    Oil levels rise when engine gets warm, that is where there is a "full cold" and full hot" marked on most vehicles dipsticks.

    If you mark dipstick before you ride, then ride all day, wait until next morning to check dipstick oil level. ( cold mark to cold mark)

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mod shop fzr/sho seat and hood
    By og in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 07-04-2011, 11:27 AM
  2. Fix for GIO and Plug prob??
    By fussy1 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 60
    Last Post: 04-09-2009, 03:07 AM
  3. Help! GIO and now water in oil!!!
    By fairlanex in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 05-23-2008, 09:42 AM
  4. GIO and Our Oil Siphons
    By Ultra250xryder in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 05-22-2008, 07:42 PM
  5. Spening money and slowing down
    By river_rider in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-25-2006, 01:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •