Results 1 to 6 of 6
  1. #1

    Join Date
    Aug 2012
    Location
    Tuscaloosa,ALABAMA
    Posts
    48

    need some help with timing.

    hey guys,im just looking for a little help on my 96 sl 780.okay when i bout it the electric stator was shot,i got one off ebay,put it in and its getting spark but its not firing up.i think it has something to do with the ignition timing but im not sure.if anyone can help me or knows if it could anything else please let me know what and how to fix it.
    Thanks


  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Welcome to The Hulk

    Start simple, is there spark?

    If you installed the stator per the service manual, then it is not timing (unless the shaft key is broken or you did not re-install it).

  3. #3

    Join Date
    Aug 2012
    Location
    Tuscaloosa,ALABAMA
    Posts
    48
    yes its getting spark,i just took the old stator out and put the new one in,didn't go by the manual......and the key is fine too

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    There is a timing mark that needs to be aligned with the seam of the 2 engine case halves. Did you do that?

  5. +1 by:


  6. #5

    Join Date
    Aug 2012
    Location
    Tuscaloosa,ALABAMA
    Posts
    48
    no i didn't know about that,ill try it
    thanks

  7. #6

    Join Date
    Aug 2012
    Location
    Tuscaloosa,ALABAMA
    Posts
    48
    thank you man that did it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need some help with minor hull repair
    By stingray152003 in forum Yamaha Open Discussion
    Replies: 15
    Last Post: 02-01-2008, 07:52 AM
  2. Need some help with gas valves
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 08-13-2007, 11:54 PM
  3. Need some help with a 650 LX
    By utahnewbie in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 05-04-2007, 11:59 PM
  4. I Need Some Help With My Shark !!!!!!
    By sleblanc in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-20-2006, 03:17 PM
  5. Need some help with adjust a thrust
    By AaronC in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-10-2006, 06:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •