Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 78
  1. #1

    Question 2002 Polaris Genesis engine is getting hot and locking up in the water

    hi i need help i have a 2002 Polaris Genesis that i just put a new engine in. that all started with it stalling in the water for no reason, it would start right back up and in a few min die again.

    i found that the engine was hot to touch and even the driveshaft coupler so i had the engine looked at and he said the driveshaft was bad and the pistons were bad as well.

    so i got a new engine and I'm having the same problem its getting real hot after only a few mins of driving and stalling, the driveshaft coupler was not even turning, but came loose with a punch of the start button. plus is hot as well.. please help


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Just to be clear;

    Old engine was hot to the touch and stalling.

    Technician diagnosed the drive shaft was bad and the pistons were bad.

    You now have a new engine installed. When running it in the water the new engine is also getting hot and stalling. In addition, the drive shaft coupler is not turning?

    Have I got ths correct?

  3. #3
    yes that is right, old engine was getting hot and couler to and own is is doing the same to the new engine i gess this means it wasn't the engine

  4. #4
    now i just went through the water system and found no blocks in the tubes i found a bet of dirt in the little screen filter at the muffer, but that after it go through the engine im gessing.. i open up the thermostat that had too, pieces of somethings hard in it. im not shore if it was jamming the pop off valve.. the thermostat, needs to be replaces.. do you think this would make the engine so hot and stall..

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Blockage inside the thermostat housing is not good.

    Also check the water inlet screen inside the jet pump nozzle. It is a small back plastic mesh square on the inside of the nozzle.

    When the cooling system is working properly you shoud be able to put your hard on any part of the engine or exhaust without burning your skin. It should be very warm but not so hot that you can not touch it.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    The drive shaft coupler is a bonded rubber unit. It should not have any slippage and it should not get hot.

  7. #7
    hi i check the pump screen its clean as it comes. the coupler im talking about is right on back of the engine with the wrist berrings in it the driveshaft set in there thats what get hot as will and something there is locking up and stop the engine.. i was wondering if the engine is hot will this stick this is driving me crazy i have so much money in this i would never beable to sale it, not that i would now i no more about it then anything lol i checked the impaller and houing and they look great

  8. #8
    Polaris John's Avatar
    Join Date
    Jul 2012
    Location
    St.Petersburg Forida
    Posts
    269
    +1
    5
    Is the engine getting oil? I would check that I have seen yamahas do the samething when the oil lines fail.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by travis ingram View Post
    ... The coupler im talking about is right on back of the engine with the wrist berrings in it the driveshaft set in there thats what get hot as will and something there is locking up and stop the engine..

    i was wondering if the engine is hot will this stick ...

    ...i checked the impaller and houing and they look great
    If the engine is getting hot then that is one problem.

    If something in the drive line is getting hot that is a separate problem.

    If the impeller is not turning properly that is also a seperate problem.

    There are no wrist bearings in the driveline. Please refer to the diagram in the next post and tell us which part is getting hot.

    When the machine is in the water and before it overheats, does it actually work? Does it go as fast as you expect it to?

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    This is the driveline diagram for the 2002 Genesis.

    You can find parts diagrams for every section of every Polaris at this web site;
    http://parts.polarisind.com/Assemblies.asp

    Click image for larger version. 

Name:	ImageUploadedByTapatalk1344740411.673777.jpg 
Views:	200 
Size:	33.9 KB 
ID:	280198

Page 1 of 8 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Genesis i... Got some Engine questions
    By sirdave4 in forum Polaris How To & FAQs
    Replies: 71
    Last Post: 05-11-2015, 02:19 PM
  2. 2002 Polaris Genesis is losing 1000 RPM at top speed now and then
    By travis ingram in forum Polaris Open Discussion
    Replies: 20
    Last Post: 09-06-2012, 10:58 AM
  3. Replies: 7
    Last Post: 05-18-2012, 06:01 PM
  4. 2002 Polaris Freedom Engin Light flashing and will not crank
    By snackcakes97 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-16-2011, 05:38 PM
  5. WTB Cylinder, Head and Injectors for a 2002 Polaris Genesis
    By polarisbuyer in forum Polaris Classifieds
    Replies: 3
    Last Post: 08-24-2008, 02:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •