Results 1 to 6 of 6

Thread: Bad injector

  1. #1
    yol937's Avatar
    Join Date
    Jul 2011
    Location
    Nc
    Posts
    1,071
    +1
    160

    Bad injector

    How do u tell if u have a bad injector I have 80lb injectors and I'm thinking one of them is bad?? My fpr gauge will show around 58 lb of fuel pressure and as soon as u turn the ski off the gauge goes straight to zero any ideas??


  2. #2
    yol937's Avatar
    Join Date
    Jul 2011
    Location
    Nc
    Posts
    1,071
    +1
    160
    Somebody has to know Something

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    If your using a FPR then its normal for the pressure to drop.

  4. #4
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,693
    +1
    40
    This is normal!Mine does it as well.I have bosch 48s that are flow tested!

  5. #5
    yol937's Avatar
    Join Date
    Jul 2011
    Location
    Nc
    Posts
    1,071
    +1
    160
    Quote Originally Posted by beerdart View Post
    If your using a FPR then its normal for the pressure to drop.
    The only reason I was concerned about it cause it never done that before it would hold fuel pressure for atleast a min or so then slowly leak down but now it drops instantly after being shut off.. One of my bolts came loose on my fuel rail and it caused the o ring around the injector to blow out and after that is when it started leaking down instantly

  6. #6
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253
    Could also be the check valve in the pump. Mine will drop to half and then slowly bleed down from there after shutting it off. How is your fuel pressure when riding? Ive also seen the hose in the tank split or a clamp break that will allow all the pressure to bleed off. Injectors hardly ever go bad. They may get gunked up from sitting for a long time, but the rarely ever just go bad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 gp1300r. bad injector o rings??
    By mad-italian in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-13-2015, 01:24 PM
  2. Clogged or bad injector on 04 Gp1300r?
    By chevyrocks3 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-01-2013, 07:58 AM
  3. Replies: 42
    Last Post: 08-17-2012, 05:54 PM
  4. Possible bad injector?
    By Stockrxp in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-22-2011, 07:55 AM
  5. Bad injectors?
    By inteljd in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 09-05-2007, 09:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •