Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    I rebuild my rxpx with block 2004

    hi all , i'm not best in english ( sorry for my bad english ) .

    I deaded my block on my rxtx's engine , and i have rebuild it with block of 2005 ... But now i have air pressure in my oil gauge .
    ( i'm not want use front hold front pump on my engine ... )
    Are you idea difference block 2005 and 2008 ?
    I have thrown the 2008 block


    Can you explain me with pic , because I was barely understand the technical langage in english ???

    thank you


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    what head are you using?

  3. #3
    Quote Originally Posted by skidoochris View Post
    what head are you using?
    TY for help me ...
    all 2008 exepte block cylinders 2004
    ( head 2008 )

  4. #4
    No body for me ?

  5. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476

  6. #6
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    what is your native language? we might be able to find someone to help you in your natyive language?

  7. #7
    I'm you're brother french ... i know english , and I manage to communicate with you


    I havent got problème with the head ... i have delete billet pressure no prodlem...
    But i haven't drilled front engine



    Thand you againe very much

  8. #8
    Bonjour,

    You MUST do two things:

    1. Drill the block like the photo you posted. This will solve the air pressure problem.
    2. You must remove the oil restrictor valve at top of the block. If you do not do this, you will destroy your cam and rockers for lack of oil pressure to the head.

  9. #9
    the oil restrictor valve is already removed yes ...
    But i havent drill block ... I'm working on ...
    I'm on vacation a few days ... Reassembling in September

    TY

  10. #10
    Quote Originally Posted by Sylvius View Post
    I'm on vacation a few days ...
    I thought you said you were French; you should have said "I'm on vacation a few WEEKS", LOL

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 05-15-2014, 06:27 AM
  2. Replies: 3
    Last Post: 07-17-2013, 04:09 PM
  3. I need help urgently with my rxpx 2009!
    By quiddo15 in forum 4-Tec Performance
    Replies: 19
    Last Post: 02-02-2013, 08:01 PM
  4. Replies: 2
    Last Post: 08-25-2008, 04:53 PM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •