Results 1 to 7 of 7
  1. #1

    Join Date
    Sep 2009
    Location
    n.j.
    Posts
    457

    04 rxp issues ?'s

    #1; what should the idle RPM be at both on trailer and in the water?
    #2: tried to gps(garmin nuvi) yesterday, water temp 86*,air temp around 86*, x-charger,42's,4" kanaflex up front,solas 14/19 light chop 7900-8100 rpm.. got max speed of 67, on flat water I got to 8150 rpm but garmin died on me but the stock speedo was pinned at 70mph as i know it will not register any higher. i guess the chop is what was slowing me down? it does pull hard though.
    is this where i should be?
    when you all give top speed numbers, what are your water conditions? i know that i need to gps it again but just trying to get some feedback. thanks


  2. #2

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251
    Quote Originally Posted by jersey785 View Post
    #1; what should the idle RPM be at both on trailer and in the water?
    #2: tried to gps(garmin nuvi) yesterday, water temp 86*,air temp around 86*, x-charger,42's,4" kanaflex up front,solas 14/19 light chop 7900-8100 rpm.. got max speed of 67, on flat water I got to 8150 rpm but garmin died on me but the stock speedo was pinned at 70mph as i know it will not register any higher. i guess the chop is what was slowing me down? it does pull hard though.
    is this where i should be?
    when you all give top speed numbers, what are your water conditions? i know that i need to gps it again but just trying to get some feedback. thanks
    Your rpm seems good if it's stock ECM.
    you should never rev your ski on the trailer as it needs the resistance from the water.
    Speed should be around 73-75 ish with your mods

  3. #3

    Join Date
    Sep 2009
    Location
    n.j.
    Posts
    457
    yes stock ECM and i never rev on trailer. just looking for trailer idle rpm and water idle rpm. my rpm at idle in the water is 1700. is that normal or high or low?

  4. #4

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251
    Quote Originally Posted by jersey785 View Post
    yes stock ECM and i never rev on trailer. just looking for trailer idle rpm and water idle rpm. my rpm at idle in the water is 1700. is that normal or high or low?
    Yes that seems about right. I don't know about the trailer I've never checked sorry.
    Check out my video on YouTube search rxp x loughor I think theres shot of my idle speed.

  5. #5

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251
    Water temp 60 air temp 74

  6. #6

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    71-72 w/ good conditions w/ your setup.

  7. #7
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    1850 rpm at idle is normal on trlr, and close to that in the water

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 RXP issues
    By danny3535 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-24-2012, 06:19 PM
  2. 04' rxp issues
    By drallab in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-15-2010, 10:14 PM
  3. 04' RXP Issue
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-27-2009, 11:30 AM
  4. More Issues with my 04 RXP
    By 04RXP22 in forum 4-Tec Performance
    Replies: 23
    Last Post: 04-20-2008, 09:13 AM
  5. 04 RXP issues. Need helpful info.
    By 04RXP22 in forum 4-Tec Performance
    Replies: 33
    Last Post: 04-04-2008, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •