Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    06 VX 110 Deluxe Cavitation issue

    My ski will only go 22-25 mph and I can't seem to get it fixed. Had the jet pump serviced, impeller replaced, and exhaust system checked for obstructions and still the same issue. The engine sounds very strong starts right up...but it acts the same as my Seadoo does with the learning key lanyard....it just refuses to go over 25. What am I missing here?


  2. #2
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    how are your RPM's? Have you inspected the intake grate?? Why did you replace the impeller and with what?? Was it damaged?

  3. #3
    I don't recall exactly what the RPMs were at but they were high for the speed. The impeller and jet pump were serviced to try to solve this issue. The old impeller had a few nicks but nothing severe. It was replaced with a yamaha high alt...I don't know what the pitch of it is. When you say inpect the intake grate you mean make sure there is nothing in there right? Well the whole jet pump was off so I'd assume we'd see an obstruction unless there is something specific I should be looking for.

  4. #4

    Join Date
    Jul 2012
    Location
    Oakland, Maine
    Posts
    355
    +1
    19
    Did you have the pump housing (wear ring) replaced when you had the new impeller installed? The new impeller will be useless if the wear ring is worn because you won't have the tight seal needed between the impeller and ring.

  5. #5
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Quote Originally Posted by sbaird4000 View Post
    Did you have the pump housing (wear ring) replaced when you had the new impeller installed? The new impeller will be useless if the wear ring is worn because you won't have the tight seal needed between the impeller and ring.
    I would think it would have to be real bad to limit it to 25 mph..??

  6. #6
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Ok so you say like your Seadoo so are you sure you are doing 7k rpms when u are going 25 mph? Or is the motor bogging? How does the ski feel to 25 mph?

  7. #7
    Quote Originally Posted by r33pwrd View Post
    Ok so you say like your Seadoo so are you sure you are doing 7k rpms when u are going 25 mph? Or is the motor bogging? How does the ski feel to 25 mph?
    What I meant by that is....my Seadoo has a learning key that governs the speed to 35 mph but with the Adult key it can do 60+ mph. The engine feels strong, just seems to not be translating to the prop. I did check the wear ring also, I don't recall the measurements off hand but I had a manual and I used a feeler gauge to test the space in between the impeller and the wear ring.

    This may of may not be of help. When I hook it to the hose at home and rev the engine it doesn't seem as though it is spraying out water like it should. On my Seadoo again for example...hooked to the hose and rev'd to 7k it shoots water clear across the shop, the yamaha will spray water but a mere couple of feet at best.

  8. #8
    Quote Originally Posted by leedanger View Post
    What I meant by that is....my Seadoo has a learning key that governs the speed to 35 mph but with the Adult key it can do 60+ mph. The engine feels strong, just seems to not be translating to the prop. I did check the wear ring also, I don't recall the measurements off hand but I had a manual and I used a feeler gauge to test the space in between the impeller and the wear ring.

    This may of may not be of help. When I hook it to the hose at home and rev the engine it doesn't seem as though it is spraying out water like it should. On my Seadoo again for example...hooked to the hose and rev'd to 7k it shoots water clear across the shop, the yamaha will spray water but a mere couple of feet at best.
    Sorry I realized I didn't answer your question. Yes...I feel confident that the RPMs are at least over 6k @ 25mph.

  9. #9
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Quote Originally Posted by leedanger View Post
    Sorry I realized I didn't answer your question. Yes...I feel confident that the RPMs are at least over 6k @ 25mph.
    Than
    it has to be a pump or inlet issue. Does your pump tunnel look good? Any water in the ski after riding it?

  10. #10
    By pump tunnel do you mean the space between the intake grate and the pump? If so, it look ok to me. There is no water in the ski at all and never had any cooling issues with it what so ever. I put it back on the water and it is at 5500 rpm at 25 mph.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replacement prop for 06 Yamaha VX 110 Deluxe
    By SD1976 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 05-04-2015, 10:17 AM
  2. VX 110 Deluxe Upgrades
    By mark10 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 12-09-2008, 02:29 PM
  3. Parting out 06 VX 110
    By disgruntled cowboy in forum Yamaha Classifieds
    Replies: 14
    Last Post: 11-07-2008, 11:25 PM
  4. FS 06 VX 110 parting out
    By disgruntled cowboy in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 10-10-2008, 08:11 AM
  5. VX 110 Deluxe
    By Vengeance Racing in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-18-2007, 10:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •