Results 1 to 3 of 3
  1. #1

    Unhappy Newbie with 97 GP1200 and ski starts and then dies!

    I just bought a 97 GP1200 and ran it for a few hours in June. It ran great once warm, but was hard to start. I just completed installing new oil lines with the better clamps, and installed a primer kit (removed choke plates). I am fairly meticulous, all hoses and clamps back on, primed oil lines, etc. Upon starting now, it will initially fire quick with the primer kit, run for 3 to 5 seconds, and die out. If I try to give it throttle, it kills it. I can keep it running by pumping the primer valve. I had it on the water, same thing. Would fire right up. If at idle, it would die out in 3- 6 seconds. If I gave it gas, it would just puts out. I could keep it running by pumping the primer valve. I made no adjustments to the carbs when they were off. I have:

    1. cleaned and regapped plugs (newer)
    2. confirmed fuel is making it into the carbs by sucking directly from a bottle
    3. compression tests good

    I have read you should not need a carb adjustment after a primer kit. Previous owner said motor was rebuilt (looks like it has been pulled), so maybe the carbs where rebuilt and tuned different than factory? Please suggest possibilities to troubleshout. Thanks so much!


  2. #2
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    Sounds like its most likely a fuel/carb issue. Kinda sounds like the symptoms of creased fuel pump check valves. You might wanna dig into the carb and look for at those check valves. Search on here for info on the check valves creasing and you should find some good info with pics.

  3. #3
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    Also, where did you tap into for your primer pump, ON, RESERVE, or the return line?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question with 97 GP1200 rebuild
    By GPM in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 04-30-2012, 03:20 PM
  2. Newbie with new to me skis (coming out of storage)
    By Seabass in forum 2-Stroke Performance
    Replies: 15
    Last Post: 06-02-2011, 01:23 AM
  3. newbie with 97 sltx and bad MFD
    By beans in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-28-2009, 12:45 AM
  4. what carbs on 97 gp1200 and 98 xlt760
    By Glenn Briglio in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 08-20-2009, 10:57 PM
  5. TXI starts and then dies
    By Dirtbiker2007 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-23-2007, 12:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •