Results 1 to 6 of 6
  1. #1

    Need Help 2001 Virage

    Just purchased a 2001 Virage. Need your help.

    Symptoms are;

    Popping at 3000-4000 rpms
    Jumps from 4000 to 5000
    Hates to run between 4-5k
    Runs fine at 5200-5700
    WOT goes to 6100 then slows to 5800

    Starts fine
    New SBT motor
    New Stator
    New Plugs
    New Reed Valves
    Checked timing
    Checked Flywheel and key
    Checked fuel system and by-passed water separator and shutoff valve(Ran new fuel line from pick-up straight to carb)
    Rebuilt carb and set pop-off. Not a carb issue. Tried a carb from another ski.


    It seems like a fuel issue but just checked inside of tank and nothing.

    Coil? Plug wires? CDI?

    Thanks for any help!


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Jumping from 4000 to 5000 is just the motor "getting on the pipe" I would think losing RPMs would be a fuel issue. Have you checked/cleaned/rebuilt the carbs? Does your ski have the grey fuel lines? That motor should turn 65-6600 RPMS

  3. #3
    Quote Originally Posted by BryanP View Post
    Jumping from 4000 to 5000 is just the motor "getting on the pipe" I would think losing RPMs would be a fuel issue. Have you checked/cleaned/rebuilt the carbs? Does your ski have the grey fuel lines? That motor should turn 65-6600 RPMS
    Not a carb issue.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by Billj View Post
    Not a carb issue.
    A failing magneto stator or CDI can cause issues.

    So can loose or corroded electrical connections, frayed ends on spark plug wires, etc.

  5. #5
    New Stator.
    No Corrosion, nothing loose. UGH

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by K447 View Post
    A failing magneto stator or CDI can cause issues...
    Got a spare CDI?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 07-06-2015, 12:38 PM
  2. Need Help 1200 Virage TX
    By FLASH56 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-11-2010, 07:23 AM
  3. need help>>> 2001 virage tx
    By Polaris 01 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 05-10-2010, 03:29 PM
  4. need help 2001 900 STX
    By wavehummer in forum Kawasaki PWC Performance (2-stroke)
    Replies: 17
    Last Post: 08-03-2007, 01:23 PM
  5. Need Help With Virage..
    By Alex3012red in forum Polaris Open Discussion
    Replies: 10
    Last Post: 01-17-2007, 07:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •