Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    just picked up 2011 ultra 300x...issue

    I just picked used with 12 hours on it. First run won't run over 50mph or 6500rpm. Am I doing something obviously wrong? Not in economy mode, at least the indicator is off. The speed and rpm recorder says 64 mph and 7500rpm +/-.


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    just picked up 2011 ultra 300x...issue

    Are you using the orange key ?
    Why are you saying 50 mph but ski says 64? How much boost r u making ?

  3. #3
    Did you check all the things that you were told to check on the other post before buying this ski?

  4. #4
    Quote Originally Posted by meangreenman View Post
    Did you check all the things that you were told to check on the other post before buying this ski?
    I did and all things checked out. I did however notice the plugs weren't new but they all looked good and had good color upon inspection. When I first started it on water it did seem loaded up...idling burpy. It cleared out off idle tho. Off idle it seemed to run fine but wouldn't top 6500 rpm or so.
    I did pull the plugs about an hour ago... one was wet and could possibly been fouled. I will put all new plugs in tomorrow (from dealer) and try it tomorrow. I'm not real experienced with 4 strokes and fouling...thought that wasn't common?? If the plugs are original that could be an issue to I presume. Hopefully it's this simple!

  5. #5
    What was the compression reading on each cyl?
    How is the exh filter condition?
    Any oil contamination inside the intercooler?
    How is the s/c belt condition, any sign of slippage or excessive wear/rubber dust, etc.?
    How is the s/c rotor condition?
    Any exhaust leak from faulty hose/clamp?

  6. #6
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    just picked up 2011 ultra 300x...issue

    Ru using the orange key ?

  7. #7
    Quote Originally Posted by meangreenman View Post
    What was the compression reading on each cyl?
    How is the exh filter condition?
    Any oil contamination inside the intercooler?
    How is the s/c belt condition, any sign of slippage or excessive wear/rubber dust, etc.?
    How is the s/c rotor condition?
    Any exhaust leak from faulty hose/clamp?
    Im using the Fast key. It went slower with SLO key.
    Exhaust filter looked almost new when inspected at dealer.
    I'll check for an exhaust leak but frankly if isn't the plugs it's going back to the dealer. I purchased an extended warranty...Im not knowledgable enough to mess around with the s/c on this thing. I'm pretty technical but a lot of what's on this motor is new to me.

  8. #8
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    just picked up 2011 ultra 300x...issue

    I hope it's a gttp extended warranty.

  9. #9
    Quote Originally Posted by FIRE0021 View Post
    I hope it's a gttp extended warranty.
    Factory warranty was expired so gttp wasn't an option.

  10. #10
    wideopenski's Avatar
    Join Date
    Jun 2011
    Location
    Pennsville, New Jersey
    Posts
    24
    I had a similar problem, if it is the same as mine was you will notice your boost won't go above 8-10#. If that is the case pull the intercooler and look for milky oil, if present clean with gas.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just picked up my 2000 ultra 150 with 29 hOurs on it! I'm back!!!
    By waverider1200 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 20
    Last Post: 02-21-2015, 02:14 PM
  2. Just picked up a 2011 RXTx
    By rxtscott in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 08-04-2011, 12:17 AM
  3. Just picked up an Ultra 150 ('99) Few Questions
    By s4orce in forum Kawasaki PWC Performance (2-stroke)
    Replies: 10
    Last Post: 07-29-2011, 08:24 AM
  4. Just picked up a 07 ultra 250x, what to look for while thoroughly looking over it?
    By 98gsxl951 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 35
    Last Post: 04-07-2011, 07:35 AM
  5. just picked up my ultra 250
    By GDM in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 04-30-2007, 09:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •