Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    Join Date
    Jun 2011
    Location
    hopewell,Va.
    Posts
    139

    gpr revs up but goes nowhere

    went out on the river today and got up to speed and i heard a funny noise like pump vibration so i slowed down but when i tried to accelerate the ski would rev up but would not plane out. it will still move at idle speed but when i give it the throttle it wont go. i have installed the pump seal kit because i had a similar situation with the jet drive last summer. put the pump seal kit and used 4200 during reassembly. impeller is still turning. seems like the pump broke seal again. i thought the seal kit would eliminate the problem of pump cavitation. any advise will be appreciated.


  2. #2
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    I asusme you check the intake grate?

  3. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by rich.allen View Post
    went out on the river today and got up to speed and i heard a funny noise like pump vibration so i slowed down but when i tried to accelerate the ski would rev up but would not plane out. it will still move at idle speed but when i give it the throttle it wont go. i have installed the pump seal kit because i had a similar situation with the jet drive last summer. put the pump seal kit and used 4200 during reassembly. impeller is still turning. seems like the pump broke seal again. i thought the seal kit would eliminate the problem of pump cavitation. any advise will be appreciated.
    check for a branch or something caught between you impeller and pump liner.

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,269
    had a guy with an ice bag stuck around his prop...tough plastic wouldn't come off or get processed ( it was a yamaha)..vibrated horrid and didn't plane out. Tell the ski to say ahhh and look down the pump tunnel with a good flashlight.

  5. #5
    silvercrxsir's Avatar
    Join Date
    Sep 2011
    Location
    ocala,fl
    Posts
    334
    +1
    8
    I had a rubber exhaust coupler come loose,engine would rev up but ski would barely make it up the ez port

  6. #6

    Join Date
    Jun 2011
    Location
    hopewell,Va.
    Posts
    139
    i checked the pump tunnel today no foreign objects stuck inside. i tried to turn the impeller to see if it was loose and it was still tight. i think the pump may have broken seal, might have not used enough 4200 during assembly. i am going to take everything back apart and clean it up and 4200 the heck out of it this time and see what happens.

  7. #7
    Superman! fivespeedsteed's Avatar
    Join Date
    May 2010
    Location
    Midlothian VA
    Posts
    1,058
    +1
    14
    if a wear ring gets bad enough they will do this, did you check the clearance between wear ring and impeller

  8. #8

    Join Date
    Jun 2011
    Location
    hopewell,Va.
    Posts
    139
    i read in a thread that the oem wear ring is an aluminum ring with a stainless sleeve pressed into it and that over time the corrosion will cause it to swell and collapse onto the impeller. can i check the cearance with a feeler gauge? from what i can see the ring is not touching the impeller. does the cavitation come from too much claerance between the impeller and the ring?

  9. #9
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,269
    Quote Originally Posted by rich.allen View Post
    does the cavitation come from too much claerance between the impeller and the ring?
    yes

  10. #10
    DB Kustomz Zxspyderz's Avatar
    Join Date
    Jun 2008
    Location
    Eustis, Fl
    Posts
    83
    +1
    2

    Re: gpr revs up but goes nowhere

    Also be sure to check the splines on the drive shaft to the intermediate shaft. Gotta pull the motor forward some and the pump out. My friends gpr just had same symptoms. Stripped splines on a 2000 gpr. Upgrading his to the 02 setup for now. His would barely creep across the water but rev fine in and out of water. Hope this helps any!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Revs up but doesnt move
    By M.lev in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 07-11-2014, 04:15 PM
  2. 2001 Polaris Virage,701,3 seater,red engine.Engine revs up but won't move forward.
    By felderlostnspace in forum Polaris Tech Tips and Info
    Replies: 3
    Last Post: 10-09-2013, 12:35 AM
  3. Ski revs up but doesn't go anywhere - hdtechboomer
    By hdtechboomer in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-03-2013, 10:53 PM
  4. 2004 Yamaha XL700 waverunner-revs up but won't pick up speed
    By novak in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-24-2011, 05:51 PM
  5. Gp1200 Caviatating! Will rev up but go NOWHERE HELP!
    By ktyamaha36 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 03-30-2010, 02:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •