Results 1 to 4 of 4
  1. #1

    Polaris 96 SLT 780

    I have a Polaris SLT 780 and it runs fine, Idles great and everything problem is when I'm going the engine just dies. The display still works when it dies. It will start right back up go 50 mph then just dies again. I have been took to it could be electrcial, but I have no idea! Need help


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Welcome to the Hulk! I would be most afraid that it is dying due to a lack of fuel at high speed. Please start by reading through here: http://polarispwcknowledge.shorturl.com/

    You should focus on the Piston Wash areas and take a look at your wash to see how it compares. If you continue to ride, and it is a lean fuel condition, you will permanently damage you engine.

  3. #3
    Quote Originally Posted by BlueFishCrisis View Post
    Welcome to the Hulk! I would be most afraid that it is dying due to a lack of fuel at high speed. Please start by reading through here: http://polarispwcknowledge.shorturl.com/

    You should focus on the Piston Wash areas and take a look at your wash to see how it compares. If you continue to ride, and it is a lean fuel condition, you will permanently damage you engine.


    A couple of years ago we took it to a dealer and they said one of the piston are bad and they replaced it. If the fuel is the problem I have read to get a three port fuel pump. Is this your recommondation? I also have a SLT750 should I replace both at the same time? Should I focus on the fuel first then if that doesn't work look at the electrcial?

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    You will want to keep the fuel pump on the 780, but buy a rebuild kit for it. Go ahead and upgrade the 750 to a trippple outlet pump, as well as all of the other fuel system upgrades outlined in the link provided.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris oil tank, cap, valve from 96 SLT 780
    By tg2861 in forum Polaris Classifieds
    Replies: 0
    Last Post: 07-20-2008, 12:51 AM
  2. 96 slt 780 exhaust bolts
    By la90043 in forum Polaris How To & FAQs
    Replies: 69
    Last Post: 04-27-2008, 09:16 PM
  3. 96 SLT 780 Crankcase
    By kabadou in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-07-2007, 11:37 AM
  4. 96 SLT 780 f/a upgrade?
    By Ibreakstuff in forum Polaris PWC Performance
    Replies: 2
    Last Post: 05-16-2007, 10:27 AM
  5. 96 SLT 780 questions
    By BBCaprice in forum Polaris Open Discussion
    Replies: 13
    Last Post: 05-14-2007, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •