Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    07 RXT won't top out

    I know this has probably been answered a hundred times but I couldnt ever find the same situation as I'm having.
    My 07 RXT runs great for starters. It just never gets over 7,100 RPM and tops out at 60 MPH
    It seems everyones sc problems are only hitting lower RPMs and lower MPH than I am.
    I'm new to jetskiing and this is my 1st ski I've owned. Any help or direction would be greatly appreciated


  2. #2
    forgot to add the ski is completly stock. The sc has been rebuilt about 50 hrs ago and I dont know if it has ceramic washers or not.

  3. #3
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    Check the slip on the SC and check the impeller for damage.

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Could have a boost leak, low charger slip, damaged prop, and wear ring,or pump bearing issue.....

  5. #5
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131
    Take a look in your pump area and make sure your OPAS hose is connected at the top of the pump. If that hose comes loose the OPAS paddles will stay in the dropped down position and you'll never do faster than 60 mph.

  6. #6
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    I always start with a new set of plugs! Very cheap and it atleast eliminates one possible cause.

  7. #7
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131
    Quote Originally Posted by psycho rxp View Post
    Could have a boost leak, low charger slip, damaged prop, and wear ring,or pump bearing issue.....
    Quote Originally Posted by monaroman76 View Post
    I always start with a new set of plugs! Very cheap and it atleast eliminates one possible cause.
    I agree with the above. However, the RXT 215's had OPAS paddles that raise and lower based on water pressure coming from the pump. If the tube coming from the pump pops loose or is disconnected the ski will ride perfectly but you'll be stuck right at the speed and RPM you're currently maxing out at. Basically the paddles will never receive the water pressure and they'll be stuck in the down position creating constant drag. I've forgotten to reconnect this tube a few times after doing pump work. So before anything else, check and make sure it's connected. If not, it takes two seconds to fix.

    It's part #33 on this diagram.

    Click image for larger version. 

Name:	Screen Shot 2012-08-17 at 9.32.43 AM.png 
Views:	217 
Size:	59.5 KB 
ID:	280598

  8. #8
    thanks for the replies. I checked the OPAS hose and its on. it seems the it will take a ton of water pressure to pull the paddles up. i pushed them up with my hands and wow they are way stiff. I havent had time to tear into the sc and see if its slipping yet. Hopefully I will get time here soon to check on the other things you guys have suggested. thanks again and I will post what I find out. It sounds like I am pulling the sc here for the season anyway and having Jerry rebuild it. I want to make sure it has the upgraded washers in it before I go trashing the motor. Just bought a RIVA intake grate for it I need to install also. I will pull the pump out and check the wear ring and impeller too. thanks again

  9. #9
    So I put my new Riva top loader grate on today and siliconed every bolt hole on the ride plate and around the ride plate edges. I decided to block off the OPAS port because I blocked the paddles in the top position. I decided to look everything over on the pump and venturi and I noticed the nozzle was loose so I pulled it off and the plastic spacers that go around the top and bottom pivot bolts were destroyed letting the nozzle move up and down. Could this cause any issue with not hitting top speed or RPM?

  10. #10

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,600
    +1
    28
    i suspect when you get your SC back from Jerry your RPMs will be where they should be (around 8000), if you have no boost leaks. Keep us posted.
    Last edited by Sundance; 08-28-2012 at 11:19 AM.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 rxt won't come out of reverse.
    By Juice It in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-18-2011, 11:32 PM
  2. 07 RXT won't go above 5600 rpms....need help
    By Fatty in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-16-2010, 11:43 PM
  3. Ultra 150 freshly rebuilt, bogging down and won't top out!
    By koryk in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 07-13-2010, 10:46 PM
  4. 07 RXT tops out at 55?
    By Tundra310 in forum 4-Tec Performance
    Replies: 26
    Last Post: 06-10-2010, 08:46 PM
  5. TOPS Valve on 07 RXT
    By lafjax in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-10-2007, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •