Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Join Date
    Jul 2012
    Location
    Kathleen, FL
    Posts
    55

    Nitro Please help WGS replaced and still Drops RPM's

    Changed the WGS (new) and made a big differance 6200-6250 RPM's but that was short lived, dropped off RPM's shortly after back down to 5500-5600 RPM's Turned off ski and re-started the RPM's came back for a short time then back down to 5500-5600 RPM's. Any idea's
    Thanks in advance.


  2. #2
    supermac's Avatar
    Join Date
    Dec 2005
    Location
    Mooresville, NC
    Posts
    406
    +1
    10
    knock sensor, plugs or bad gas. put 93 in it.

  3. #3

    Join Date
    Jul 2012
    Location
    Kathleen, FL
    Posts
    55
    New plugs,Fresh 93 gas

  4. #4

    Join Date
    Jul 2012
    Location
    Kathleen, FL
    Posts
    55
    Anybody else have any clue's

  5. #5
    Jake Speed's Avatar
    Join Date
    Jan 2007
    Location
    New Jersey
    Posts
    220
    +1
    11
    It sound like the boost control valve is bleeding off boost on the turbo . So oil that puppy up and make sure it's working.

  6. #6

    Join Date
    Jul 2012
    Location
    Kathleen, FL
    Posts
    55
    boost control valve??? What is that???

  7. #7
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Quote Originally Posted by Jake Speed View Post
    It sound like the boost control valve is bleeding off boost on the turbo . So oil that puppy up and make sure it's working.
    Good advice... now get back to work on that hood so we can do some riding!

  8. #8
    Quote Originally Posted by Vman View Post
    Good advice... now get back to work on that hood so we can do some riding!
    or buy a 98 challenger and all your worries will melt away!

  9. #9

    Join Date
    Jul 2012
    Location
    Kathleen, FL
    Posts
    55
    So nobody knows what this boost control valve is????

  10. #10
    Jake Speed's Avatar
    Join Date
    Jan 2007
    Location
    New Jersey
    Posts
    220
    +1
    11
    Quote Originally Posted by Squirl View Post
    So nobody knows what this boost control valve is????
    It's on the back side of the turbo and has a vacuum hose from the WGS on it and there is a 1/4 inch rod that go's in to the turbo. So oil that up real good and move it back and forth with plyer's

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. please help first ski, and having issues
    By scd2747 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 02-25-2012, 12:31 AM
  2. Nitro please help.
    By Budga in forum Honda Open Discussion
    Replies: 1
    Last Post: 03-06-2011, 08:20 PM
  3. please help almost sunk and now wont start
    By gtxforlife88 in forum 4-Tec Performance
    Replies: 28
    Last Post: 08-15-2010, 04:02 PM
  4. R-12X Surges and then RPMs drop. GURUs please help
    By BFAmazon35 in forum Honda How To & FAQs
    Replies: 6
    Last Post: 03-30-2008, 12:43 AM
  5. Please Help, Hit rock and Scratched Gelcoat
    By Rspeed in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 09-06-2007, 06:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •