Results 1 to 4 of 4
  1. #1

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113

    CDI Questions - 1995 SLT 750 CDI gets hot when battery is connected

    What would cause a CDI box to heat up very hot as soon as you hook up the battery cables? After it heats up it is no longer useable. This is on a 1995 SLT 750.

    I have a No Spark issue and swapped a good CDI box from another ski to see if it would fix the No Spark issue and it got very hot and it won't work on my other identicle ski.

    Any ideas before I go any farther? Thanks.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Test your stator. You may have a short in the wiring or the stator itself. Is the battery connected correctly? Reverse polarity can fry these things.

  3. #3

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113
    ANYONE else?

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by BryanP View Post
    Test your stator. You may have a short in the wiring or the stator itself. Is the battery connected correctly? Reverse polarity can fry these things.
    Sounds like solid recommendations to me. Did you perform these tests?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Questions on the 1995 SLT 750 engine
    By VDRIVE79 in forum Polaris How To & FAQs
    Replies: 31
    Last Post: 08-24-2015, 02:36 PM
  2. 1995 SLT 750 Questions
    By leprechaunjohn in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-03-2009, 11:55 PM
  3. Please Help 1995 slt 750 cdi
    By sinclair in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-25-2008, 03:21 PM
  4. Couple questions (94 SLT 750)
    By Soulbait in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 08-02-2007, 12:06 AM
  5. Just purchased a 1995 SLT 750.. Questions
    By daveo13 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-08-2006, 03:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •