Results 1 to 7 of 7
  1. #1

    Join Date
    Jul 2012
    Location
    Beach Haven, LBI, NJ
    Posts
    24

    2012 RXT-X 260... IBR Sticking on?

    When loading onto trailer - I didn't get high enough on the bunks and had to iBR reverse off with heavy throttle. When off the trailer, and after releasing the left hand lever, hitting the throttle didn't give me forward (slight panic here)- the machine stayed in reverse and kept accelerating backwards. THe iBR light remained on - again no left lever in use. The only way to stop the craft from going backwards was to hit the kill switch, restart and gas it. Who said boat ramps weren't entertaining?

    It happened twice..... same scenario - hot loading the craft. And for all the comedians out there - I haven't stopped taking the meds and the floor mat wasn't stuck on the accelerator a la Toyota Camry.

    Anybody else experience this?


  2. #2
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Never happened to me...however there is quite a delay sometimes.

  3. #3
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    wiring, ibr fuse, ibr water ingress, ibr worm drive damaged...

    Those are the things i'd check

  4. #4

    2012 RXT-X 260... IBR Sticking on?

    Happened to me once early in the break-in on my 2012 RXP-X 260. Hit the breaks and held the lever to spin around after stopping, and when i released the lever it stayed in reverse. I had to shut it down and restart for normal operation. I checked for codes with my V-tech tuner and found none. At that time i found a thread about some querks during break-in, but I can't find it now.
    It only happened once (first day out if I remember), and I now have over 50hrs with no more issues.

  5. #5

    Join Date
    May 2012
    Location
    Northern MN
    Posts
    85
    Had mine do that when the battery was low, I jumpstarted off another machine and it went into limp mode and stuck in reverse, I had no neutral or forward. Letting it sit on the jumpers for a minute after starting it again seemed to fix my problems.

  6. #6

    Join Date
    Jul 2012
    Location
    Beach Haven, LBI, NJ
    Posts
    24
    Exactly how NEpro describes it.

  7. #7
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    FYI. Slightly off topic, but I NEVER ride a ski on or off the trailer. I have seem a few people suck up rocks at various ramps and ruin the day, not to mention prop, wear ring, pump etc.

    It may take an extra 30 seconds to winch the ski up, but it's better then a $300+ repair, IMO.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 16
    Last Post: 08-07-2013, 03:54 PM
  2. 2012 RXT-X 260 break in question
    By Dax_Thornhill in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 06-22-2012, 01:00 AM
  3. 2012 RXT iS 260 Steering and other issues....
    By Birdman in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-31-2012, 03:23 PM
  4. 2012 rxt x 260 is ? on slow speed mode
    By paul1968 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 03-27-2012, 01:16 PM
  5. 2012 rxt is 260 info needed
    By paul1968 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 03-05-2012, 01:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •