Results 1 to 2 of 2
  1. #1
    onefast96svt's Avatar
    Join Date
    Jun 2011
    Location
    Raleigh, NC
    Posts
    25

    Help on P1520 code on my GTX

    I went for a ride today going about 50 or so to keep up with my GTI. After about 10 min of straight riding I got the constant beep, oil light, and saw a code for what I thought I saw was p1520. I cut it off waited for about 30 min. Then started it up see if I could make it to the marina. As soon. As I pull unit went off again. I coasted to the dock and googled the code. I read to check all harnesses and stuff like that and to look for leaks in hull. No leaks no loss harnesses. We rode back not going over 5k rpms no more than possible. Made it back to put on the trailer and no codes were thrown but I did cut it off one time on the way back to watch a huge V8 boat get on it. Of course while riding slow and worried about know telling what is wrong with it this time every noise I hear I couldn't help but think, what was that?

    So now I'm not sure as wha I should check because I cant find a p1520. I'm guessing it may be oil preasure switch, oil preasure regulator, or oil pump because everyone has talked about these but no real answers from what I can see. If anyone has any suggestions feel free to add.

    One other thing! I did just have my s/c rebuilt after bearing went out. I'm not sure but I'm hoping that the dealer cleaned out the old oil. I'm guessing they changed it, but am going to change it tomorrow just to see if I see any metal parts in oil.


  2. #2
    onefast96svt's Avatar
    Join Date
    Jun 2011
    Location
    Raleigh, NC
    Posts
    25
    On another forum I'm told it must be code p0520. It could be because my glasses were wet and gauges too. I've got a OPS ordered already. It's just agrivating having to go 45 min to put it in water to test if if code is fixed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. please help me ! power exhaust valve very hot on my GTX 787 .
    By hendyho in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-20-2009, 11:46 PM
  2. Nitro, HELP on my f12x
    By timmy_philson in forum Honda How To & FAQs
    Replies: 15
    Last Post: 02-12-2008, 05:51 PM
  3. Question on my GTX
    By DeeGee in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-14-2006, 10:26 AM
  4. Pics of Nils/Mark Thru Hull Exhaust on my GTX S/C LTD
    By Red Devil in forum 4-Tec Performance
    Replies: 26
    Last Post: 12-20-2005, 05:00 AM
  5. Hulk's pitch on my GTX
    By Red Devil in forum 4-Tec Performance
    Replies: 18
    Last Post: 10-31-2005, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •