Results 1 to 7 of 7
  1. #1
    Devildog9999's Avatar
    Join Date
    Nov 2011
    Location
    Niagara Falls, NY
    Posts
    181

    2005 GTX Limited 215 - Steam?

    Hey All,

    I have an 05 GTX Limited SC/IC ski. Took it out yesterday and ran wot for about a mile and a half and when I stopped there was a TON of steam coming out of the ass end. Not smoke - but steam. I had no indicator that the ski was in overheat mode and it ran fine all the way. Is this normal after a wot run? Water temp is at 78*.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    It's normal.
    It's the water cooled exhaust system doing its job.
    Wot for only a mile....
    Let her rip....

  3. +1 by:


  4. #3
    Devildog9999's Avatar
    Join Date
    Nov 2011
    Location
    Niagara Falls, NY
    Posts
    181
    Thanks - Appreciate it. This thing has been "off" since the blower rebuild, and we are trying to get to the bottom of it. Dealer says nothing is wrong, but the GPS shows a top speed of around 60, and the "stock" MPH gauge is showing 74 - so something is very wrong.

  5. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    60 mph gps is a normal- good speed for that ski.
    The dream meter is always off...
    It's not worth fixing.
    You can spend a lot of $$$$ and its still going to read high.
    I've seen newer skis that are 255hp gps at 63-64mph but show 70+ on the dream meter..

  6. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    If your looking for a cheap way to get 2-3mph then pitch/tune your prop..

  7. #6
    Devildog9999's Avatar
    Join Date
    Nov 2011
    Location
    Niagara Falls, NY
    Posts
    181
    Before the rebuild I was seeing a top speed on the GPS of 68.5 - so I lost quite a bit. Just trying to figure it out. It just does not "feel" the same since the rebuild. Even the launch seems to be lacking power where it used to jump out of the water.

  8. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Check your wear ring and prop.
    A lot of launch power is gained with a good wear ring.
    They do wear out...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Boost question for a 2005 GTX Limited 215
    By Devildog9999 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 12-20-2011, 08:26 PM
  2. 2007 GTX Limited 215
    By driveumhard in forum 4-Tec Performance
    Replies: 34
    Last Post: 04-14-2009, 07:07 PM
  3. Fs: 2007 rxt gtx limited 215 ecu
    By Kohl531 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 01-23-2009, 10:34 PM
  4. 2005 GTX IC 215 Lower speed and rpm's
    By juanco123 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-07-2008, 01:14 PM
  5. 2005 GTX Limited giveaway!
    By JAG in forum Open Discussion
    Replies: 19
    Last Post: 01-27-2007, 08:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •