Results 1 to 2 of 2
  1. #1

    Smile 1999 Genesis with no spark

    Hello, I'm new to the site, so if there is a better place to post this question please move my thread. I purchased my first pwc last week. I'm not so mechanical so I might have made a mistake! Ran it for 1/2 hour first time out. started easy, ran full throttle, very responsive. stopped using stop button. tried to go for another ride 1 hour later and couldn't start it. tried every configuration of throttle, choke, and carb spray into carbuerator that I could think of. Started up after much trying. ran for 30 minutes again with no problems. stopped with stop button. Next time out couldn't get it started at all. back at home on trailer, it started once and I let it idle for 10 minutes....stopped it with stop button and it wouldn't restart. Same problem now....won't start. It seems to crank strong. I cleaned battery connections, load tested battery and O'reilly's auto parts said it held good charge under load. I replaced the plugs with new ones, same NGK's as were in it initially. NO SPARK! I check the fuel line that returns to tank from carbeurator just in case and it pumped fuel when cranking with throttle, so I think I'm getting good fuel. I opened up a box (that's the non-mechanic talking who doesn't know what the box is called) with electrical connections and a reset button to see if it might be wet. Everything looked dry and connections were spade type with grease in them. pulled a few apart to see if they were corroded and they were not. Put those back together. I opened up another box on the opposite side of the hull with connections in it and that box looked dry too. Can someone tell me how to figure out which part of my starting system is faulty? I can give you numbers from the boxes if that helps or post pictures. I also pulled down the lanyard button while cranking just to make sure that wasn't the problem. Thanks for any help anyone can give. You'll probably have to dumb it down for me a I said....I'm no mechanic.

  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Rochester, New York
    Welcome to The Hulk!

    Check my signature links for answers to all your questions. Sounds like your LR 502 is bad.
    Last edited by ghostinstallations; 08-24-2012 at 07:33 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 SLTX with NO Spark
    By Bru-Bro in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-09-2011, 01:12 AM
  2. 1999 SLH with no spark
    By hbjohnny in forum Open Discussion
    Replies: 1
    Last Post: 03-15-2011, 07:32 PM
  3. 2002 Genesis I with No Spark - Need Help
    By Jeffa15 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-01-2010, 02:10 PM
  4. 1999 GTXL 951 no spark :(
    By tzpetri in forum 2-Stroke Performance
    Replies: 19
    Last Post: 08-15-2008, 06:01 PM
  5. 2000 Polaris Genesis FFI-No Spark HELP
    By Rogaty17 in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 06-13-2008, 09:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts