Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    Sep 2009
    Location
    Richmond Hill, Ontario
    Posts
    137

    Good compression on STX 12f?

    I'm wondering what would be considered good compression numbers on a 2007 STX 12-F

    Also wondering...are there any special tricks to doing the test? Holding throttle open, etc, etc?


  2. #2
    > At sea level, about 230-235 psi on calibrated gauge.
    > Throttle 1/2 open
    > All plugs removed
    > Battery fully charged, min 12.6 VDC producing min 400 rpm.

  3. #3

    Join Date
    Sep 2009
    Location
    Richmond Hill, Ontario
    Posts
    137
    Thanks for the response! Is there a number of strokes that it should be able to do it under?

  4. #4
    4 to 6 strokes.

  5. #5
    If you have low compression and happen to find a detonated piston or two (or even more somtimes), don't just put in new parts and think everything would be fine.
    You need to what caused the problem in the first place. Check all cooling passages for blockage or lack of flow that might have caused hottrer running engine.
    You don't want the same problem to reoccur on your rebuilt motor.
    Also there are at least 3 versions of 12F ECU and the latest would be the best. The 9-digit P/N is stamped on the ECU.

  6. #6

    Join Date
    Sep 2009
    Location
    Richmond Hill, Ontario
    Posts
    137
    It seems to get around 180psi on all of the cylinders around what I think is the sixth stroke, but a little more and it gets above 200-210psi. Not sure how much of an effect it has but I am about 690ft/210m above sea level.

    I can't get the machine to stay running. So just working through the options. I bought the machine a couple weeks ago, I launched it...and then it over heated. I only had the thing running for about 2 minutes in the lake total, the over heat light came on...I shut it off. I gave it a short break, then I had it running for about 30 seconds (max) to work my way to shore.

    I thought its hard starting issue was due to some water possibly getting into the motor via exhaust....But maybe it is something more.

    I originally bought it with a broken fuel pump (I did not know) I replaced it with a GSS342 Walbro, new fuel filter, and there appears to be tonnes of fuel at the fuel rail.

    I was thinking that it could be old fuel from last year, but it did start up on it before..so it can't be that bad.

  7. #7
    did you get a factory service manual ?

  8. #8
    Quote Originally Posted by vwmikey99 View Post
    > it over heated. I only had the thing running for about 2 minutes in the lake total, the over heat light came on
    > broken fuel pump (I did not know) I replaced it with a GSS342 Walbro, new fuel filter, and there appears to be tonnes of fuel at the fuel rail.
    > hard starting issue
    > old fuel from last year
    Overheating, Walbro fuel pump, old fuel, hard starting, .... it sounds like you are trying to confuse yourself.

    Work on the overheating issue first.
    Does it overheat when running on garden hose?

  9. #9

    Join Date
    Sep 2009
    Location
    Richmond Hill, Ontario
    Posts
    137
    The 12F service manual yet, though I do have the 15F manual right now for starters.

    I can't work on the overheating issue because it doesnt seem to be running long enough to over heat

    Though, before a couple weeks ago when I did get it running (after the fuel pump install) it was not overheating on the garden hose. On the hose it was spitting out water out of pisser.. In the water it was just steam.

  10. #10
    The 15F manual should work just fine for your troubleshooting since they have exactly the same electronics, wiring harness, cooling system, etc. The only main difference is the piston/compression.

    If can't run long enough to work on overheating, let's work on the running issue first.

    How long does it run before it stalls out?

    If you fiddle the throttle, would it run little longer?

    Do you smell any oily substance in the exahust or any noticeable smoke (not steam) when starting?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How hard/easy is it to replace display (speedometer) on STX 12F
    By danm125 in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 07-24-2012, 10:37 PM
  2. How long to swap out a hull on STX 12F
    By Dezl_Dr in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 07-23-2011, 10:48 AM
  3. What's considered good compression on ultra 150?
    By screamindemon in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-23-2010, 05:26 PM
  4. whats good compression on a wave jammer?
    By Joe Stang in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 05-17-2010, 10:18 PM
  5. Newb needs info on stx-12f please help!
    By Fulltitl429 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-09-2009, 11:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •