Results 1 to 10 of 10
  1. #1

    Need help frustrating yamaha 1200 issue

    I have a yamaha xl1200 with the 1200 powervalve motor, it will idle fine and run at about half power and reach 44mph every once in awhile it will kick in and climb up to 55 or 7000 rpm. I just rebuilt the carbs and changed the jets to 110 pilots and 120 mains and changed the needle and seat to 1.5 and took off the accelerator pump and added riva air filters. The power valves cycle when shut off and the hole lines up and I removed the fuel flapper. Any help would be great.


  2. #2
    A child of five would understand this. Go get one. pierowman's Avatar
    Join Date
    Sep 2011
    Location
    Seattle, WA
    Posts
    280
    +1
    7
    Compression test results?

  3. #3
    120 in each cylinder

  4. #4
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    check if the pv motor works, while in the water.ride the ski w/o the seat.

  5. #5
    Ok so I rechecked the compression and its 120 - 90 - 100. Even though it kicked in a few times while riding and would do 55mph does it need a new top end?

  6. #6

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    It's so easy to just pull the head and take a peek inside

  7. #7
    I pulled the head and the front cylinder with 120psi looked good and was wet with oil the middle cylinder piston had pitting all over the top and on the head same with back cylinder just not as bad. There is no oil in the hull and all the lines are attached. Do the oil pumps fail sometimes or do you think the carbs were just not letting enough gas in? Click image for larger version. 

Name:	WP_000047.jpg 
Views:	63 
Size:	73.6 KB 
ID:	281290Click image for larger version. 

Name:	WP_000049.jpg 
Views:	56 
Size:	53.9 KB 
ID:	281291Click image for larger version. 

Name:	WP_000048.jpg 
Views:	62 
Size:	44.2 KB 
ID:	281292Click image for larger version. 

Name:	WP_000052.jpg 
Views:	64 
Size:	41.3 KB 
ID:	281293Click image for larger version. 

Name:	WP_000052.jpg 
Views:	64 
Size:	41.3 KB 
ID:	281293Click image for larger version. 

Name:	WP_000050.jpg 
Views:	55 
Size:	43.7 KB 
ID:	281294

  8. #8
    Also the cylinders appear to be in decent shape there are a few scores but I can't feel them with my fingernail. Also when I would rev it up on the trailer I would barely tap the throttle and it would rev up higher than my other skis. Could this mean an air leak? and is that usually caused by intake gaskets or could it be crank seals?

  9. #9
    A child of five would understand this. Go get one. pierowman's Avatar
    Join Date
    Sep 2011
    Location
    Seattle, WA
    Posts
    280
    +1
    7
    Leak down test can answer your question about the crank seals or intake. Usually lean runaway is when you cut power it still runs or revs high as soon as you start it without you hitting the throttle. Try choking it and see if that changes things for the better.

  10. #10
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    All of that pitting is from something bouncing around in there. Either pieces of ring, piston, power valve, and or bearing. I would also pull all the caps of the power valves and make sure they are still attached. Usually they tighten up from carbon build up, the pin holding them in gets loose and falls out, then the valve contacts the piston and mooshes the ring groove shut causing compression loss. You should probably pull the motor and remove the cylinders.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help!! 95' Yamaha Raider
    By ozman087 in forum Southeast
    Replies: 0
    Last Post: 07-13-2009, 01:33 PM
  2. Neeed help quick yamaha 1200
    By fishman1000 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-24-2008, 02:57 AM
  3. Need Help, Bogging, Yamaha waveventure
    By lousieg55 in forum Yamaha Old School Skis
    Replies: 27
    Last Post: 06-26-2008, 11:39 AM
  4. Need Help: 1999 Yamaha Ls2000
    By BEER30 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 07-09-2007, 11:39 AM
  5. Need help with Yamaha Jet ski ... No speed
    By welterracer in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-19-2007, 10:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •